Openhab.log stopped

I have openhab installed on a RPI. Everything worked fine until Midnight today. From this time on there are no logs or errors written in the openhab.log file.
events.log works fine as before
Karaf console however shows all errors/logs (which is weird… can someone explain that?)
Any hints where to look or what to try? Thanks a lot in advance

What’s the condition of your sd card? Any power glitches recently?

I had this issue my card was corrupt. I did a backup of config and Imaged my card again. The card still works great it just became corrupt for some reason.

If nothing changed recently I suggest starting here. If you have a second sd card image it and boot up to test this theory. If you have been making changes then it could be something else.

it could be a permissions issue? chmod 777 the log file and see if that helps


Thanks forgot about that!

Hi all,

thanks for your suggestions. chmod 777 did not change anything … but good idea, thx.

Finally it was just a power cycle of the RPI which solved it. Which is interesting since “sudo reboot” did not help either. After replug the power cord, openhab is up again and the log is getting filled.

Thanks for your support!

1 Like