Openhab Log Viewer (frontail) empty after some time

Same issue here. Had to disable zram.

Seems to be a bug (OH3.1 M4). RPi 4.

Disabling ZRAM may shorten the life of your SD card. ZRAM was used to prevent/lessen the writing on the SD card.

1 Like

I made a fresh install of openhabian and OH3.1 on rpi4 over the last few weeks.

I also experience this problem - and i’m not keen on just disabling Zram.

Does anyone know of other solutions ?

1 Like

I’d like to know too. I have same symptoms on my previous installation and recently on a fresh installation running OH 3.1.0 on a RPi 4. Seems like it’s not a good idea to disable zram and rebooting openhab every 3 days isn’t ideal.

@mstormi mstormi
Would you have any input on this ?
I guess it seem like a systematic issue related to Openhabian and Zram.

I’m a linux/raspberry novice - but fairly ok in IT stuff generally.
Anything I can do to help debug this problem

No. And to ping people is unwanted here.


I had to reinstall my openhabian due to an update error. I downloaded and installed the latest version:

The copy and paste strategy worked great and everything is running as before for now. Unfortunately, one important function is no longer working and that is the log viewer (frontail), which has always run perfectly and provided important and necessary information. The folders and directories were created cleanly and are filled. I have also followed all the tips from Udo:

but it does not show me any entries in http://openhabian:9001/

Did you use a backup to restore your settings ?
What is the content of org.ops4j.pax.logging.cfg in /var/lib/openhab/etc ?
Do files /var/log/openhab/events.log /var/log/openhab/openhab.log exist and content is added ?

Hello Wolfgang_S,

Sorry for my late feedback, but I hardly get to Openhab or programming due to my enormous workload.

With the new updates and openhabian-config, the log viewer (frontail) suddenly worked.

I think it might have been a bug or something in my installation didn’t run completely cleanly. Fortunately, it works again and I can comfortably view and correct the errors.

Thank you very much for your always quick and helpful feedback!

1 Like