OpenHab not even pingable after upgrade from 3.4.3

Hi everyone,
I think I might need your help, I was running Openhab 3.4.3 on a Raspberry Pi 4 and after 2 months uptime I decided to do an upgrade through CLI so I run
sudo apt-get update
sudo apt-get upgrade
and that was it… Not even pingable anymore.
Any ideas?

Plug in a monitor and look for errors during boot.

Something apparently went wrong with the upgrade. This is an operating system problem, not an openHAB specific problem.

I’m going to do that right now.
Thank you!

Monitor shows nothing, with either plugged or unplugged ssd
I screwed up…

Black screen, no cursor ?
What did you you after “sudo apt-get upgrade” ?

black screen…
I did: sudo reboot

Black screen could mean that the screensaver is active. Keyboard is connected as well and does not activate the screen again ?
Does your router show a new / an other IP address for your Pi ?

Yes, I have connected mouse and keyboard without any success, also the raspberry is not showed in the ip table of the router either in the subnet scan.
This is crazy, on the other hand SSD is working properly, I connected it to the computer and i can see files and folders

That sounds like you boot from SSD and you also tried to do a forced boot by pulling the power adapter and after plugging in the power adapter you still don’t see any reaction on the monitor ? This would look like the Pi or the power adapter is dead.

Thank you for the reply,
both are ok, but something went wrong with the upgrade of OS as @rlkoshak mention before.
I’m on the way to a fresh install… Unfortunately.

The very bad thing is that I lost 3 years of logs :frowning:

If the SSD is fine as you say:

I connected it to the computer and i can see files and folders

Can’t you recover the files from the other computer?

This is all I’ve got in the SSD

and there is something strange

There is a strange disc format, correct me if I’m wrong

Note that a Raspberry Pi boot disk has two partitions. A Fat32 boot partition which is what you are seeing there. There is also an ext4 partition that has everything else. On a Mac or Windows machine you need to install support for the ext4.

If you are on Windows, it might be possible to mount it into a WSL2 environment. If not Paragon soft has a driver with a 30 day free demo period. You could also install a VM running Linux to access the file system.

I’m not sure about Mac. Maybe you can install support through brew?

1 Like

An other possibility is to boot a live image like SystemRescue

1 Like

I’ll try windows because I’didn’t find any luck on macOS with M1 Silicon.
I just wanted to back up InfluxDB and restore it to the new Installation.

Where should I start If I’d like to migrate old InfluxDB from 3.4.3 installation to the new 4.0 4M?
Where should I look for the files? Do you have any walk through to suggest?

That’s all outside the scope of openHAB and since I don’t use InfluxDB :person_shrugging: .

it’s probably enough to copy over the /var/lib/InfluxDB folder but I don’t know.

1 Like

I managed to get into ext4 partition through Windows machine, grab both
and replace the ones from the new installation with them, without luck…
I’m desperate…
Permissions are a big deal for Linux as well… I straggled to manage…

Don’t just blindly replace folders. Go to InfluxDB’s docs and/or forum and find out what you need to do for that. Then go to Grafana and do the same there.

Yes indeed, file ownership and permissions are a very big deal in Linux.

1 Like