OpenHab not getting data from z-wave devices

Tags: #<Tag:0x00007faecbe85680>

Hi,

I just found out that OpenHab does not get data from my z-wave devices. If I turn on my Fibaro Dimmer 2, by clicking the switch on the wall, the status in OpenHab stays Off even though the light is on. But I can control the switch from Openhab.

I also have some z-wave wall plugs, and they have the same issue. Furthermore I dont get any data about Power usage etc.

If I control my Hue lights through the Hue app, OpenHab will update as expected.

Please help!

This will happen if associations are lost, which was an issue in the 2.4 version of the zwave binding. This is resolved in 2.5 M1 and newer versions of the binding. So, you can upgrade or manually go through all of your devices (in Habmin!) and reset all of the associations. For battery powered devices, the change will require the device to wake up, so it may take a while unless you manually wake them up. If you do not upgrade, the issue will reoccur.

Hi Scott.

Thanks for taking time to help me!

I updated openhab from 2.4.0 to 2.5.0 M1 (running on a windows machine - i deleted some files and copied new files to the folder as described in https://www.openhab.org/docs/installation/windows.html)

Unfortunately the problem is not gone - but as understand your post it should be working fine now? Or do I still have to reset the associations?

Anyway, I tried to reset the associations, but I could not figure out how to do that. Can you guide me? (Of course I would prefer not to reset all associations if possible…)

Best regards,
Michael.

This makes me think you’ve never set them. In Habmin> Configuration> Things> select your device and look under Association Groups. This is where you can add devices (in your case, the controller) to the Association Groups. However, these devices have a lot of configuration parameters that can also affect associations. Read through all of those and and make sure they are set properly. You may need/want the manual for this. The device database has manuals, but has two entries for this device, depending on the firmware revision (up to firmware 3.4, 3.5 and newer). You can see the firmware revision for your device listed under the device’s Attributes section in Habmin. I do not have this device, but maybe someone that has one can assist further. Updating to 2.5M1 should prevent the associations from being lost once they are set.

Hi,

I tried everything but I cant get it working. I also tried to make a brad new installation (2.5.0.M1) and only mapped my z-wave power plug. Still I don’t get any data regarding power usage. It used to work in my old setup using 2.3.0 Stable. The first time I installed OpenHab (one year ago or more) it just worked when I mapped the things and items.

Could the problem be related to my z-wave stick and all the z-wave nodes paired to it, or is it related to Openhab (im not sure what information is stored in the z-wave stick, what is stored in the z-wave device, what is stored in Windows (drivers etc) and what is stored in Openhab)?

Thanks.

To be honest, I‘m experiencing the same issue. With OH 2.3 I received all updates from my Fibaro dimmer, with 2.5.0.M1 I don‘t get any updates…

Hardware: Aeotec USB Z-Wave Plus stick, Fibaro FGD-212 Dimmer 2

Without logs, it’s impossible to tell what the problem is from this side of the screen. Associations are set and stored in the device, but OH reads them, stores a copy of them, and can set them on the device. If you’ve used Paper UI to configure the device, these could have been incorrectly changed or reset. You need to use Habmin for configuring zwave devices to prevent this. It’s always possible there is a new bug too :slight_smile:.

Which configuration parameters and associations have you set?

@sihui, are you familiar with these devices?

Yes, I have one.
It is one of my oldest devices and has worked with all kind of binding versions: 2.3, 2.4, 2.5 Snapshot.

One need to proper calibrate the FGD212 on the specific bulb used and one need to set the association group Lifeline to the controller, that’s it. Make sure you are setting the correct button config: switch, button, mono, bi-stable or whatever.
Also make sure you are using the correct channels:

Switch FibFGD212_1_Sw  { channel="zwave:device:uzb:node37:switch_dimmer1" }
Dimmer FibFGD212_1_Dim { channel="zwave:device:uzb:node37:switch_dimmer1" }
Number FibFGD212_1_Pwr1 { channel="zwave:device:uzb:node37:sensor_power1" }
Number FibFGD212_1_Kwh1 { channel="zwave:device:uzb:node37:meter_kwh1" }
1 Like

Maybe try what I did with a thermostat I had issues with?

Hi,

In associations, I set Controller as Lifeline (using habmin).

I also tried to delete this node completely from the system (I did not un-pair it with the z-wave device but I deleted it completely from Openhab).

After that I searched all files in the folder userdata/sjondb for the device, but it was not there. Then I restarted Openhab and added the device using habmin - but it still wont send power usage information.

When I turn this device on or off using habmin it takes from 4 to 10 seconds before the device responds.

When I turn the device on or off using the button the device, this information is never sent to openhab and it is not shown in the events log in openhab.

I just made a Factory Reset of my Aeotec z-stick gen5 and paired the power switch. Now it is working as expected.

Now I have to pair all other devices and start all over…

This reset the configuration parameters to the device’s defaults.

:man_shrugging:

If you made one, you can restore your stick from backup.

Damn, now my Fibaro Dimmer 2 does not behave…

The Electric Meter (watts) is not updated correctly. When I change the dimmer I sometimes get a new value for the power (watts) but it looks like the value is from the previous setting. And sometimes it does not update at all. Right now the dimmer is turned to 0% (off) but the power is showing 18 watts and stays there.

Im getting tired…

Regarding associations, I have tried setting all groups to Controller. I also tried setting only the first group to Controller (and the first and the second, and the first and the second and the third etc…).

Regarding other settings, I tried quite a lot of combinations. I have sent a screen dump but I tries a whole lot of other combinations.

By the way, the current tests are made on a new computer, a new Openhab installation. I only added one thing, the Fibaro dimmer and two items (Dimmer and Electric meter watts). Tried both Paper UI and Habmin, but it is the same issue.

Thanks @rossko57, I have now set the deprecated flag to help choosing the correct channels.

Thanks, Power1 is working!!

But where did you get the screen dump above?

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list