OpenHab not getting data from z-wave devices

Tags: #<Tag:0x00007f2fbe6e95c0>

Dear all.

Thank you very much for your help! Its really appreciated!!

Unfortunately I got a new (old) problem with one of my “Fibaro Dimmer 2” 's. When I operate the dimmer using the switch on the dimmer, this information is not sent to Openhab. The firmware version is different from the ones working. This one has firmware version 3.4 (not working). The rest has version 3.5 (working). All setting looks identical. I tried mapping all channels but no luck. I also set the Lifeline to the controller.

Double check your association group. Don’t associate any other groups except Lifeline.
If it still does not work please provide a debug log.

I enabled debugging, turned on the dimmer (using the switch on the dimmer) and turned it off after 20 seconds. OpenhabDebugLog.txt (241.2 KB)

Which node number?

grafik

its node 6

And where did you get this screen dump from? :slight_smile:

https://www.cd-jackson.com/index.php/openhab/zwave-log-viewer

Thanks, i’m still learning…

What did the log tell you?

Sorry, have been out of town.

Which channels are you watching for state changes? Looks like that are the wrong ones, you need to use the channels for endpoint 1:

Switch FibFGD212_1_Sw (gRestore) { channel="zwave:device:uzb:node37:switch_dimmer1", autoupdate="false" }
Dimmer FibFGD212_1_Dim (gRestore) { channel="zwave:device:uzb:node37:switch_dimmer1", autoupdate="false" }

I have that channel mapped:

You are missing the state updates for the switch_dimmer1 channel.
Make sure you are setting the association through HABmin, not PaperUI:

The lifeline was already set like that.

I’m out of ideas, sorry.

OK, but thanks a lot.

Maybe it is the firmware version?

The reports are being sent to the root endpoint - not endpoint 1. If you have changed from an older version of OH, then it might not be a bad idea to exclude the device and add it back so that the associations are completely reset.

Over the past couple of years there have been a lot of changes to ZWave associations - there are now something like 6 different versions of association command classes, and OH 2.4 and above had to change the way this was set to use the newer command class versions. Sometimes this doesn’t get reset, and a complete reset of the device might be the best option.

I just made some findings regarding this Fibaro Dimmer 2, firmware 3.4:

Association Groups: If I set “1: Lifeline” to Controller AND “2: Send BASIC SET command class S1” to Controller, Openhab gets updated on the following channels when I control the dimmer using the switch on the dimmer: “Sensor Power” and “Dimmer Switch 1”. But there is a small bug: When the light is turned on using the switch on the dimmer, Openhab shows the dimming as 100% even though it is dimmed (eg. to 45%). (All this is different from firmware 3.5!)

Chris: I made a factory reset of my z-wave stick, and re-paired all my z-wave devices a few days ago so this should be OK i guess.

Probably this is because of what the device is sending although without the debug log, it’s hard to be 100% sure. You should not need to use the BASIC class - this will cause problems and we should try and work out what is wrong rather than try and fix the problems caused by the workarounds.

Yes, this should be fine if the device was reset. Do you have a debug log from the new inclusion and initialisation? I’d need to see how the device was configured.

I agree, it would be best to fix the real problem instead of a workaround.

Unfortunately I don’t have the debug log. Would it be any help if exclude the device and re-included it having z-wave debugging turned on?

Absolutely - that would be perfect :slight_smile: .