OpenHab Pi Login to config issue

  • Platform information:
    • Hardware: _Raspberry Pi 4 4gig
    • OS: _Raspbian (I think)


I managed to log in to the console using the password ‘habopen’ but I am now trying to load the config editor with:

sudo openhabian-config

It prompts for a password.

I’ve tried:


User prompt is:


I just don’t know what to do. All I want to do it update the system as the NeoHub binding is broken and I need to get the new build as it is fixed in there.

I’ve also tried:

sudo openhabian-update

Which also prompts for a password and I’m equally unsuccessful.

HELP! Please…


You want to update the operating system, not the Karaf container. SSH to to the machine, not the console. If it looks like this when you log in you are in the wrong place.

                          __  _____    ____
  ____  ____  ___  ____  / / / /   |  / __ )
 / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  |
/ /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ /
\____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/
    /_/                        2.5.4
                               Release Build

Hit '<tab>' for a list of available commands
and '[cmd] --help' for help on a specific command.
Hit '<ctrl-d>' or type 'system:shutdown' or 'logout' to shutdown openHAB.


It should look like (taken from the docs)

If you installed using openHABian, the username will be openHABian, I’m not sure what the default password is. From there you can run sudo openhabian-config. When it asks for the password, it’s the same as the password that you logged in with.

See for how to ssh to the machine.

Many thanks. However, no combination of username or password will let me in via Putty. I can see that I’m in the wrong place when I use the terminal (is that what’s it’s called on Linux?) on the Pi itself. I just want to get to the screen above so I can run the update but I have absolutely no idea how to get there. What am I missing?


Don’t worry, cracked it.

I don’t think I had installed to config tool, so I did that as per here:

Then it ran and I updated everything.

NeoHub integration now working!