Openhab restart periodic


(Nanna Agesen) #1

My Openhab installation has been suffering from periodic restart the last couple of days.

I get this error - I think it’s related

cmdline:        /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.conf=/etc/openhab2 -Dopenhab.runtime=/usr/share/openhab2/runtime -Dopenhab.userdata=/var/lib/openhab2 -Dopenhab.logdir=/var/log/openhab2 -Dfelix.cm.dir=/var/lib/openhab2/config -Djava.library.path=/var/lib/openhab2/tmp/lib -Djetty.host=0.0.0.0 -Djetty.http.compliance=RFC2616 -Dorg.ops4j.pax.web.listening.addresses=0.0.0.0 -Dorg.osgi.service.http.port=8080 -Dorg.osgi.service.http.port.secure=8443 -Djava.awt.headless=true -XX:+UseG1GC -Djava.endorsed.dirs=/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-1.el7_6.x86_64/jre/jre/lib/endorsed:/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-1.el7_6.x86_64/jre/lib/endorsed:/usr/share/openhab2/runtime/lib/endorsed -Djava.ext.dirs=/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-1.el7_6.x86_64/jre/jre/lib/ext:/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-1.el7_6.x86_64/jre/lib/ext:/usr/share/openhab2/runtime/lib/ext -Dkaraf.instances=/var/lib/openhab2/tmp/instances -Dkaraf.home=/usr/share/openhab2/runtime -Dkaraf.base=/var/lib/openhab2 -Dkaraf.data=/var/lib/openhab2 -Dkaraf.etc=/var/lib/openhab2/etc -Dkaraf.log=/var/log/openhab2 -Dkaraf.restart.jvm.supported=true -Djava.io.tmpdir=/var/lib/openhab2/tmp -Djava.util.logging.config.file=/var/lib/openhab2/etc/java.util.logging.properties -Dkaraf.startLocalConsole=false -Dkaraf.startRemoteShell=true -classpath /usr/share/openhab2/runtime/lib/boot/org.apache.karaf.diagnostic.boot-4.2.2.jar:/usr/share/openhab2/runtime/lib/boot/org.apache.karaf.jaas.boot-4.2.2.jar:/usr/share/openhab2/runtime/lib/boot/org.apache.karaf.main-4.2.2.jar:/usr/share/openhab2/runtime/lib/boot/org.apache.karaf.specs.activator-4.2.2.jar:/usr/share/openhab2/runtime/lib/boot/org.osgi.core-6.0.0.jar org.apache.karaf.main.Main
package:        java-1.8.0-openjdk-headless-1.8.0.191.b12-1.el7_6
uid:            989 (openhab)
count:          1
Directory:      /var/spool/abrt/ccpp-2019-01-12-06:39:15-10765

(Skinah) #2

What does java - version give you?
Is it a beta version of java?

Recommended is 32bit Zulu version 8 if ARM based even if the machine is 64bit.


(Nanna Agesen) #3

I’m using

openjdk version "1.8.0_191"
OpenJDK Runtime Environment (build 1.8.0_191-b12)
OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)

(Markus Storm) #4

That’s no error message.
And what’s your HW ?

Mind #9,#10 of


(Nanna Agesen) #5

Sorry I should be more precise:

reason:         java killed by SIGABRT
time:           Sat 12 Jan 2019 09:20:37 AM CET

I’m Running:

Centos 7.0 64Bit on at Virtual Machine
openHAB 2.5.0 Build #1496
openjdk version “1.8.0_191”


(Markus Storm) #6

SIGABRT means some other process or the kernel has killed your Java.
Dunno why that happens but it’s no openHAB issue then.
And your environment is so uncommon that any guesses on ‘why’ would be random.
Sorry you need to take the long route (check all of your OS logs, g**gle elsewhere etc).


(Nanna Agesen) #7

Thanks @mstormi

What is the uncommon part?

I’ll check log files to if I can get somewhere.

Best Nanna


(Markus Storm) #8

your OS, even in VM, and OpenJDK
I’d move to Zulu.


(Nanna Agesen) #9

@mstormi

I have thought moving to Zulu, would that be a difficult task?


(Markus Storm) #10

I wouldn’t think so but obviously that depends more on your knowledge than on the task itself


(Nanna Agesen) #11

I have no knowledge of that, I’ll dig into it and see if I can come up with an solution.

Best Nanna


(Markus Storm) #12

Note I don’t mean to say OpenJDK causes your problem.
Could as well be that Java/OH outgrows JVM’s mem limits, either because of a memory leak or because your limits are set too low (-Xmx option to java usually)


(Nanna Agesen) #13

I changed my java version - As I can see this is the recommended
Ill have to see if this solves my problem :slight_smile:

openjdk version "1.8.0_192"
OpenJDK Runtime Environment (Zulu 8.33.0.1-linux64) (build 1.8.0_192-b01)
OpenJDK 64-Bit Server VM (Zulu 8.33.0.1-linux64) (build 25.192-b01, mixed mode)

(Rich Koshak) #14

This is what was happening when PhantomJS runs amok on RPi.

@Nanna_Agesen, check the syslog and if it’s the kernel killing OH you will see it doing so there.

Also, are you running an older version of Grafana or a newer version with PhantomJS manually restored? I have seen where this causes exactly this problem on RPis, perhaps it’s a more universal problem.


(Nanna Agesen) #15

@rlkoshak

I’ll go through my logs to see what’s going on - thanks for the hint :slight_smile: