OpenHAB service won't run on Windows 10

I followed the instructions as written on the page:

Everything went well but when I try to start the server it returns an error 1067 can’t start service.
When I googled this error I found several solutions mostly related to a bad configuration file which is not the case for my setup.
After a while I tried to run the server with my own credentials and it worked. So it looks like the “localsystem” account doesn’t have the rights to start the service.
I did use an elevated command prompt to install the service, so that is not the cause of the issue.
Any suggestions?

  • Platform information:
    • Hardware: Core I3 9100/16GB RAM
    • OS: Windows 10 Pro 1903
    • Java Runtime Environment: Zulu
    • openHAB version: 2.5

thanks in advance,


If you want to try something experimental:

This provides a windows service that manages openhab without any changes to openhab configuration files. I’ve been running it for months and it works great…

Hi Tim,

thank you for your suggestion. I have openHAB running as a service, but only with admin credentials instead of localsystem. Of course I can use your tool to maybe bypass this issue, but it doesn’t solve the real problem. I am just wondering if this is an openHAB bug or something related to Windows 10 default security settings.

thanks again,


No idea actually - I’d look at the karaf logs and the event viewer to see what it’s saying when you try to use localsystem. I’m sure it’s something security related however…

I googled all the items in the forum about these kind of issues again and I found a hint that it can be caused by the JAVA_HOME environment setting. It should be a system setting and not a user setting. Apparently I overlooked this in the installation instructions.
After correcting this setting it all worked.