Openhab start.bat not running

  • Platform information:
    • Hardware: Ryzen 9/32GB/4 Tb
    • OS: Windows 10 (10.0.18362.778)
    • Java Runtime Environment: Oracle Java 8 build:1.8.0_251
    • openHAB version: 2.5.4
      I have just started trying to use openhab after seeing the Hacksmith’s video on him setting it up for automating his shop however after following the installation instructions the start.bat file does not startup. it opens for a split second before closing without any logs being generated. I have tried many install locations with no luck. I went into the command line to make sure my JAVA_HOME is fine and it returns the install as expected, so I don’t know why openhab won’t startup.
      Many thanks in advance.

A lot of possibllities Manual, but anyhow, welcome to the OpenHAB community. Perhaps the download didn’t complete correctly?
On Windows, I think OpenHAB needs to be installed in the root directory, as in C:/ openhab. Been awhile since I’ve run it on windows so could be wrong. Try restarting the pc

Run the bat file from the command line so you can see the error message and report back here.

Alright so prior to asking here i did try to move it to C:/ and restarting my pc with o luck. KidSquids idea seems to have shown me a possible problem. i now get the error

Launching the openhab runtime…
\Java\jre1.8.0_65\lib\etc\QT was unexpected at this time

I am confused about why it is trying to use the jre when I set the JAVA_HOME path to the jdk. I don’t use java much so I don’t know a solution to this error but i will look into it to see if i can solve it but any insight would be helpful.

Aight i fixed the issue! for reference just in case this happens to someone else if you have a %CLASSPATH% variable in your system variables and there is a space in the path it will cause an error, i changed C:\Program Files (x86) to C:\Progra~2 and that fixed it. Thanks for the help guys i feel kinda dumb for not trying to use command line to launch it, but hey live and learn right.

Glad it worked out for you. Tag the solution box under my comment so others that come across it will know where to look.

Squid :squid: