Openhab start on boot

Hi there

I am hoping someone could help me or point me in the right direction. I have installed Openhab and I have created a deamon. I can start it by typing sudo /etc/init.t/openhab start. But it won’t run on startup.

I am running Ubuntu 10.04


From wiki… Not sure about v.10

Set autostart

sudo update-rc.d openhab defaults
Note that for UBUNTU 15.10 and Raspian Jessie - or if you prefer using systemctl - this should be:

sudo systemctl enable openhab

Also documented in the official docs:

Sam is right, you need to do sudo update-rc.d openhab defaults or maybe (more complete) sudo update-rc.d openhab defaults 80 10

Ubuntu 10.04 is quite old. There have been two LTS versions since then! You should seriously think about using a newer base.


I should have said that I used

sudo update-rc.d openhab defaults

And i get

System start/stop links for /etc/init.d/openhab already exist.
Died at /usr/sbin/update-rc.d line 57.

I have tried removing them and adding again and still no go.

I used

To do the installation

And I can’t use newer Ubuntu because it doesn’t support my processor

You will need to observe your system a bit. Reboot and check your logfiles (/var/log/boot etc) on hints. Did you try to disable and enable the service? This “System start/stop links for /etc/init.d/openhab already exist” could also mean, that your system is trying to start openhab too early. Try sudo update-rc.d openhab defaults 80 10 for a delayed start.

But I am not guessing here. You are dealing with a Linux technicality you should be able to solve if you dig into it a little.

But again, I am not sure if the effort is worth the time, to be quite honest here. “my processor” as in old processor - as in old pc? Maybe you should think about switching to a cheap and enegry efficient Raspberry Pi? jm2c

Thanks for the advise, i have ended up changing to a different processor and i and install ubuntu 16 and it is now working.

I Think it might have been something with the boot up process but i couldn’t nut it out.