Openhab stopped working and Sitemaps disappeared

I am using openhab2 v2.1 on Raspberry pi and I have been using it for a while it was working perfectly. I use also openhab on iOS and I was able to perfectly control all my actuators and read all my sensors.

I just for the first time copied the /etc/openhab2 folder to my windows 10 using Filezilla (ssh), I made some updates to my rules and sitemaps and copied them back to /etc/openhab2.

Since then I cannot access the sitemaps, and everything is down. I even returned the rules and sitemaps as before the changes, but with no hope. on the iOS application I get nothing or sometimes service is not available error 503

I don’t see my sitemaps anymore in Habmin or Basic UI or any interface. It is like this folder has been disappeared. I tried to change the permissions of the folder to 777 but with no hope.

Any help?

What did you use to edit the files while they were on the Windows machine? It likely added Windows style newlines rather than Unix style newlines.

Always always look first for word in the logs. What do you see?

Solved! Thanks!

Took a look at the logs, the sitemaps had an error, fixed it and all is back again! But it is weird that this also affected all the rules…