Openhab Tablet on my wall with external ethernet adapter wants me to enable wifi

I have a tablet mounted on my wall and bought an external ethernet adapter for it.
With the tablet in flight mode it has an internet connection.

Opening the openhab app it works just fine. But when the tablet goes to sleep mode and i wake it again the app wants me to enable wifi connection. Which is unnecesary because i have it on ethernet.

This is a bit annoying.

I had a problem several years ago where Google Play Store would not load apps over Wi-Fi until I enabled cellular even though it could not use it. Enabling cellular allowed it looks load over Wi-Fi. Disable airplane mode and enable Wi-Fi without connecting to an SSID. It may work without complaint over Ethernet.

1 Like

This message is only shown if no connection at all is available, including vpn, ethernet, wifi, bluetooth tethering, mobile and unknown. I guess that the app tries to connect before the ethernet connection is established.
Can you post the log of the app? And can you check if you can ping the device when the screen is off?