OpenHAB UI Frozen

I have an OpenHAB installation since 3 years. Now upgraded to 4.0.1. and I can see the website under port 8080. The normal access via text in rules, etc works, the system works also and all connection seem to work. Basic Ui and the app on apple works.

But I can not access via ui under http and https. The login works and I can see an empty website with the menu on the right and left. But if I press configuration on the left nothing happens. I can not access.

I also tried to change the password, I emptied the cache in OpenHAB and cleaned the cache in my browser. I restarted the system several times.

Can somebody help me!


Hi Christoph, I just installed 4.0 from scratch several days ago, and have had very few issues with a fresh, from scratch install.
This doesn’t help your situation, but at least it may help to know that as a fresh install, it seems stable (so far).

Good luck, hope you get it straightened out.

What does openhab.log file show ? any error or warning messages ?

@Wolfgang_S If I start the UI it shows following message 7 times:

2023-08-13 10:03:25.247 [ERROR] [al.ChannelCommandDescriptionProvider] - Dynamic command description matches original command description. DynamicCommandDescriptionProvider implementations must never return the original command description. class org.openhab.core.internal.types.CommandDescriptionImpl has to be fixed.

Are there any errors in your browser console?

@JustinG Here the message from my Edge Browser:

How can I change these website informations or is it a problem with JAVA-17?

Do I also need Java 17 on my desktop pc?

Do I have to deinstall Grafana, Viessmanncare or another application? Ist it possible just with the putty-ssh?

Now I found a way to stop a binding via Karaf Console. I stopped the two ViCare Bindings for Viesmann.

I used the putty:

openhab-cli console


You have to find out the ID of the bundle

Then you can stop the binding with the following order:

bundle:stop IDoftheBinding


Now it works again! The next steps would be to renew the ViCare App

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.