Openhab vlans

Hi everyone need a few tips

I have just seperated my lan with vlans so my smart devices are on there own vlan openhab is on main lan

My main lan can talk too the vlan but the vlan cant talk too the main lan

What protocols / ports / services do i need too have running so auto discover still works in openhab?

I can create specific rules on pfsense so certain parts of the vlan can talk too the lan

Thanks everyone

Hi @Sharpy,

The answer depends upon the specifics of your openHAB setup, For example, if you are using the Network binding, and your openHAB system is on you main LAN, while the devices your are wishing to monitor are on the smart device VLAN, your monitoring will not work as you’ve noted that your “main LAN can talk but the VLAN can’t talk to the main LAN.”


I moved my openHAB setup to my iot vlan.

Seemed easiest then I only need to have one rule allowing me to reach openHAB.


This is actually working the main lan fully communicates with the vlan the only things i have noticed not working atm is auto discover & Google home groups i cant add the group for some reason

I have also thought of this i may end up doing it i just think i will have too make alot more rules if i do too allow communication to and from anything that’s on the main lan

@Sharpy you could also put the openhab pi on both vlans? I did this with my christmas light controller. I needed the broadcast traffic segregated. I manage on one vlan and broadcast data out the other. I believe the network binding could see devices on the main lan if you did this and moved the pi to the iot one.

For the google equitpment do you have the mdns repeater configured? If not this could be your problem, if the google features that don’t work use this. I had to turn on mdns repeating for my printer and chromecast.

1 Like

I don’t think i have I’m unsure about it im new too vlans so will have too check my setup and config

Chromecast discovery and casting now working i had too install Avahi on my pfsense too get this working not sure if there’s anything else not working atm

1 Like