OpenHab with Smartthings integration

Tags: #<Tag:0x00007faedb249190>

I have seen a couple of inquiries on the forum. And it “appears” as though most folks are doing a bit better on this than I am. I wanted to find an easy way to integrate what I already had for smartthings components with my openHab setup. I have been very successful with writing rules and scripts on my openhab config and would like to use that as my base for all automation. The real issue I am having is with connectivity between the two. It “appears” as though all the config is done right on the samsung side, but when I try a search i essentially get a line that says

20:35:06.349 [WARN ] [discovery.SmartthingsDiscoveryService] - Attempt to send command to the Smartthings hub failed with:

and that’s it. No additional information. So it is making troubleshooting a bit difficult. If I can get this working, this will be a big step forward for me. So any help would be greatly appreciated.

-Nick

Wanted to add an update. I have been playing with it a bit more and appear to be getting the following in the openHAB log when clicking a smartthings button. So it would appear “some” form of communication is happening. Just not sure where the breakdown is.

20:44:15.810 [WARN ] [e.core.thing.binding.BaseThingHandler] - Handler SmartthingsThingHandler of thing smartthings:button:60a7b101 tried updating channel button although the handler was already disposed.

Again, any help you folks can offer will be greatly appreciated.

-Nick

Hi Nick and welcome to the OpenHAB community! I am a former smartthings user and have been using OpenHAB about a year. For all of us to help you get your set up running, tell us what version of OpenHAB you are running and the platform you are running it on. Also important, how are you getting OpenHAB communicating with smartthings? are you using @BobRak excellent binding?

I don’t know if there’s devices that openHAB does not support (or only support using Smartthings as a gateway), but in short, integrating Smartthings (or FWIW, any automation controller) with openHAB is a bad idea and you’re better off migrating devices to openHAB (only) and I believe that’s what most forum members have done in the end.
You’re already seeing first implications of integration you wouldn’t have with OH only, and I’m sure you’ll see more if you continue.

Ive been having issues myself, with I believe multisensors, and now discovery doesn’t seem to be working.

What is your thing file look like? Have you setup the smartapp in smartthings classic and detected the openhab device in ST?

I know in the ST ide setup i was putting the wrong mac address in and was causing issues.

O.k. so it would appear that I am almost fully functional at this point. Took a tiny bit of playing. But it appears to be working. Yes I am using the smartthings binding. I have smartthings setup in both the old and new apps, and have found I have to add “some” new sensor where as others show up automatically after adding to smartthings. But currently I have many sensors working as desired. So absolutely HUGE thumbs up to @BobRak for the binding, couldn’t have done any of this without that work.

That is terrific news Nick, well done. As Markus eluded to, eventually I stopped using smartthings hub because a got a USBZ zigbee dongle. It cost about the same as one smartthings sensor and was half the price of the smartthings hub (which I still have if any one wants it) In fact, when I found OpenHAB and considered using it, working with smartthings was a prerequisite. Looking back it is hard to believe I started my journey with OpenHAB by using a JAR file binding and the config necessary on the smartthings side. It wasn’t easy for me so good on you!
I must say, it wasn’t the communications with OpenHAB that caused problems. The zigbee dongle worked fine reading communications with the smartthings sensors, the smartthings hub became unnecessary as I hadn’t attempted to learn how to write rules in smartthings (they give you a few decent ones) The smartthings sensors kept dying. I’d replace the batteries and it would work for a few days or it would report tempurature and battery level but no motion. You mentioned button, I had one of the smartthings buttons, they are cheap $15 how cool would it be to have a little button somewhere to turn all the light off or something. Darn thing never worked for more the a day or two even when brand new. Best Buy did not honor the warranty, I would not buy any of it ever again and strongly suggest others do not as well.