OpenHAB2 - Can't Convert From Celsius


I am running the latest snapshot with the test Z-Wave binding that includes security. Since I have OH2 setup, I’ve been unable to successfully set the scale of my item reports to Fahrenheit. It always reverts to Celsius. I’m using HABmin to set the value.

Any thoughts?

After talking with @chris, I’ve opened a bug report for this in ESH here.

There’s another discussion about this elsewhere right now (strangely)… Question - have you used PaperUI to see if that works? It’s suggested that this might be a HABmin issue…

Try using PaperUI to edit it. That just worked for me.

That’s strange for sure!

Until you guys said to use Paper UI, I didn’t think you could! Yes, works fine in Paper UI. Must be a HABmin problem then. I am going to close my ESH bug.

Would be really useful to have a configuration-wide default setting for temperature.

+1 on that!


I have this EXACT issue, but when I try to save in PaperUI I get a “Error 500 - Internal Server Error”. Habmin claims to do it, but it always reverts. @chris this is the issue I was discussing with you via a ticket at your site.

1 Like

Per @Ward in another thread this issue is likely due to duplicate channels if you end up not being able to save the change. To fix here are the details I used:

“There was a duplicate channel id for the thing (CT32): zwave:device:4c9537c3:node11:battery-level. I could see this when I tried to use the REST ‘PUT’ command to update the ‘config_scale’ for all the temperatures. The error was something along the lines of “duplicate channel ‘zwave:device:4c9537c3:node11:battery-level’”. This is the same error I got when I tried to add the thermostat via the ‘.things’ file. So I changed the second one to zwave:device:4c9537c3:node11:battery-level1 (which is what it should be) and removed the link to my battery item and redid the PUT command. Now all my temperatures are in the right scale. and I think I can save in Habmin too… although I haven’t tried it and don’t think I will. I will try to put in a change for the device in the db… not sure if this is shadowmite’s problem too or not.”

"You want to use get /things to get the full JSON entry for your device.

then find the entry and copy the whole thing.

Now go down to things Put /things/{thingUID} and use your UID (looks like you know yours) into the ‘thingUID’ parameter. Mine is zwave:device:4c9537c3:node11. Then edit your JSON from above… everywhere it says “config_scale”: “0” change it to a 1.

and if you have a duplicate channel entry like mine, change the duplicates name and associated item if needed. Then paste all of that modified JSON into the ‘body’ and submit the request. hopefully it returns a successful Response Code 200 and the newly updated thing. "

In my case I deleted the duplicate channel entry entirely.