openHAB2 Homematic GATEWAY_EXTRAS not reloading new Variables

Hi everyone,

I am adding some new system variables in my CCU2. But unlike new devices, the Homematic Binding does not discover new system variables. Can somebody tell me how to reload the Thing so that it discovers the new system variables?

Lutz

I also tried to remove the GATEWAY-EXTRAS Thing in the Paper UI. Thereafter the GATEWAY-EXTRAS appeard in the inbox but when i added it as a new Thing, it does not contain any Channels anymore… :unamused:

Hello lutzb,

I’ve exact the same problem.
Do you’ve solved it until now?
I couldn’t finde any information about this problem or how to solve it.

Thanks in advance
Jan

If the problem still exists with the latest version, please create an issue for this problem.

Hello Martin,
thanks for fast reply.

How can i check, if I have the latest version?
I use openHab for QNAP, Version 2.0.0.b4-2.
Homematic Binding should be 2.0.0.b4 (shown in Paper-UI).

If it’s outdated, how to update to latest version? (replace .jar files)

Thanks a lot and have a nice day.
Jan

We are now at 2.0.0.b5 and there have been quite a lot improvements in openHAB itstelf and also the Homematic binding.
I don’t know whether it would work to update only the Homematic binding. It would definitely better to update the complete openHAB installation.
Don’t know whether there is a package for QNAP available.

Good morning Martin,

thanks for your help.
I will try to update the whole installation.

kind regards
Jan

Same issue here. I introduced a new system variable in Homematic CCU (logic value) and would like to integrate it in openHAB2. Unfortunately the channel ist not listed in the GATEWAY-EXTRAS thing. How am I able to access the new variable??

Maybe this is related to the bug I reported on GitHub:

https://github.com/openhab/openhab2-addons/issues/1663

Could be… To be honest I do not have that deep knowledge to link both issues!
Can anyone help here please? Or at least provide us a workaround - if there is one? Thank you so much!

I have still not solved my problem! Am I the only one with this problem? Or what kind of workaround would be possible? I need your help since I’m still stuck and can not add any new items anymore! Thanks a lot!

Have same problem with OH2 stable version.

There is a large update to the Homematic add-on that is waiting to be merged.
@gerrieg could tell whether the update contains a solution to this problem.

The CCU does not send any event if a new variable is available. Also i don’t know, if the openHab core framework supports adding a new Channel to an already existing Thing. I have to test it when i have time.
For the moment, delete the GATEWAY-EXTRAS Thing, do a rescan and add the Thing again.

1 Like

Hello together,

I’ve make a clean installation of openHAB 2.0.0 final.
After installation of homematic binding, the scan shows all existing devices.
But when i add the “Gateway-Extras” there where no variables or scripts listed.
Only “Reload All From Gateway” / “Install Mode Duration” and “Install Mode” is displayed.

I’ve deleted Gateway-Extras and make an rescan but no changes.

Do you have an idea? What do you expect, should i see in log file?

Thanks
Jan

@Jan-Patrick_Bruhn
Which gateway do you use? A CCU or another? If you don’t use a CCU, try to set the gatewayType parameter to ccu. Maybe the autodetection does not work with your gateway and the binding falls back to the default implementation without variables (see readme)

Hi,
i use EQ3 Homematic CCU 1.
At the Moment Gateway Type is set to “AUTO”.
When I try to set “CCU”, I got “Error 500 - internal Server Error”.
The log file shows the following:

2017-02-23 10:55:52.965 [INFO ] [ternal.communicator.client.RpcClient] - Interface ‘HMIP’ on gateway ‘43e2afc3’ not available, disabling support
2017-02-23 10:55:53.004 [INFO ] [ternal.communicator.client.RpcClient] - Interface ‘CUXD’ on gateway ‘43e2afc3’ not available, disabling support
2017-02-23 10:55:53.241 [INFO ] [ternal.communicator.HomematicGateway] - HmGatewayInfo[id=CCU,type=CCU,firmware=1.519,address=IEQ0038663,wired=true,hmip=false,cuxd=false]
2017-02-23 10:55:53.253 [INFO ] [ternal.communicator.HomematicGateway] - Used Homematic transfer modes: RF:BIN_RPC, WIRED:BIN_RPC

Do you have an idea what goes wrong?

Thanks a lot.
regards
Jan

OK, if you use Homematic then then Gateway Type must be AUTO.
Please post a full startup TRACE log (see readme)

Hello gerrieg,

I’ve saved a fully startup trace log.
How should i send it to you?
Is ist possible to sent it over a PM?

regards
Jan

Hi Jan! You can use the email in my github profile