Openhab2 installation woes

Dear folks.

I’m trying to make fresh install for openhab2.5 but having no luck.

I have the following scenario:
Have production openhab2.5 running on RPi3 with 120GB SSD, working like a dream.
I’m planning to migrate to openhab3, however I want to test this first before I make the move.

So, easy…I thought.
Let me created a second system, effectively I will perform a RESTORE on the 2nd system, used this as primary, then perform the migration to OPENHAB3.
If for any failure, I simply use my primary RPi3 system again.

So, for the backup RPI3, did I use “openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz” which I downloaded some time ago and installed via ETCHER onto 16Gb SDcard.

But the openhab portion does NOT installed.
After much debugging, have I located the issue down to the following unsuccessful script line found in the /boot/first-boot.bash:
“git clone -b master /opt/openhabian”

This provides error : “fatal: Remote branch master not found in upstream origin”

If I run : “git clone /opt/openhabian”,
then openhab installs but no “openhab2.service” is being created.

Ok, then trying the following:
After removing all efforts of openhab/git. I then tried using “apt-get install openahb2”, which completes.
I can startup the “openhab2.service”, website site comes up at x.x.x.x:8080 and then it shows busing building UI interface…after some hours…nothing happens.
It is as if this process gets stuck.

Anyone who could provide some guidance?

You mustn’t be using any that ancient image. Download the current one instead. It’ll install OH3 by default but you can downgrade in the 4X menu (if you really need to).

that is because the branches were renamed.

because default now is OH3 ( openhab.service ) for that tree.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.