Openhab2 irtrans 2.4

Hi all, after I bought a irtrans module with irdb and install the irtrans binding I still run into a problem and have no more idea. The IRTRANS Bridge is online but never the created Blaster. The Balster is every time in status INITIALIZING. I set the binding into debug mode and get only the correct irdb settings.

2019-02-08 08:24:59.540 [DEBUG] [ternal.handler.EthernetBridgeHandler] - The IRtrans device for ‘irtrans:ethernet:ed3827fb’ supports ‘1’ remotes
2019-02-08 08:24:59.643 [DEBUG] [ternal.handler.EthernetBridgeHandler] - The remote ‘samsung’ on ‘irtrans:ethernet:ed3827fb’ supports ‘2’ commands: info, guide

This configuration was done by PAPERUI. But still the same if I do it like described in the binding description.

Have someone more ideas ? That would be great.


Change it back to the manual configuration, now the Blaster was part of the bridge.

Same result

2019-02-08 09:19:53.128 [INFO ] [ternal.handler.EthernetBridgeHandler] - ‘irtrans:ethernet:wohnzimmer’ matches an IRtrans device with firmware VERSION E6.08.42 L1.11.06
2019-02-08 09:19:53.230 [DEBUG] [ternal.handler.EthernetBridgeHandler] - The IRtrans device for ‘irtrans:ethernet:wohnzimmer’ supports ‘1’ remotes
2019-02-08 09:19:53.333 [DEBUG] [ternal.handler.EthernetBridgeHandler] - The remote ‘samsung’ on ‘irtrans:ethernet:wohnzimmer’ supports ‘2’ commands: info, guide
2019-02-08 09:23:42.588 [DEBUG] [ternal.handler.EthernetBridgeHandler] - Sent a matching infrared command ‘samsung,guide’ for channel ‘irtrans:ethernet:wohnzimmer:samsung’

But no result.

Things :
Bridge irtrans:ethernet:wohnzimmer [ ipAddress=“”, portNumber=21000, bufferSize=1024, responseTimeOut=100, pingTimeOut=2000, reconnectInterval=10 ]
Type receiver : any [remote="", command=""]
Type blaster : samsung [led=“E”, remote=“samsung”, command="*"]

Items :
String WohnzimmerIRReceiverAny {channel=“irtrans:ethernet:wohnzimmer:any”}
String WohnzimmerIRBlasterSamsung {channel=“irtrans:ethernet:wohnzimmer:samsung”}

The receiver works but the blaster not.

2019-02-08 09:29:57.496 [DEBUG] [ternal.handler.EthernetBridgeHandler] - Received infrared command ‘samsung,info’ for thing ‘irtrans:ethernet:wohnzimmer’
2019-02-08 09:29:57.501 [DEBUG] [ternal.handler.EthernetBridgeHandler] - Received a matching infrared command ‘samsung,info’ for channel ‘irtrans:ethernet:wohnzimmer:any’

Looking at the Things file you have an odd " on led=“E”.

When posting Things, Items, Rules, etc… please use code fences. It’s the paper icon next to the smiley face.


Thanks, will do next time. If I remove the odd and E only - think file has an error - number requested. If I use only a high comma - Error, if I change to 1 without odd - Java error in the log. If I add the odd, message that the command was send out.

For my opinion odd is ok, it’s the same like in the example to the binding. If I use the IRServer from my laptop it works. In result Network Connection and IR is working.

Any other idea ? I have cleared the cache, same result, I have no more ideas.

Today I have make some tries with a newer IRTrans Module (V3.5). Same result - no errors but no signal send out. I have setup the Examples 1:1. If I send a signal by the WEB UI od by the IRTRans Server it works.

I enable the IRTrans Debug mode but this doesn’t help. There are no network commands available and in the WEB UI is no possibility to a debug mode.

For me it looks like that the IRTrans module don’t understand the from openhab2 network command. Have someone a working IRTrans setup (Openhab2 2.4 stable) or a idea what I can test anymore.

many thanks

Hi Christian,

even though we are now at IRtrans 2.5.6 I have exactly the same problem. The " IRtrans Ethernet Bridge" thing has status ONLINE, the blaster thing remains in status INITIALIZING. No signal is sending out.
I my case the LED is internal so it should be “I” but also tried “B” for both, no difference.

Have you got it working by now and can you give me a hint?

Does anyone have a working configuration and is willing to publish his Thing-file (or PaperUI definition), Item- and Rule-File?

Grateful for any help!


Hi Klaus,

until now i have no solution and it looks like nobody feels responsible for this binding. Thasts also a reason to validate the usage of openhab. In some cases not stable, bindungs never suported, only upgrade 1:1 to a new version without aproval of the functionality.

I know that the comunity works on a lot of topics and a lot of people brings good solution but also there are some solutions which are not working. I’m really ot happy , the reason to by a IRTrans was that a binding is there - what I learn hardly, this says nothing regarding the working.

bests, Christian

Hi Cristian,

thank you for your reply. These are exactly my experiences. Although openhab is in many parts the best solution for my smarthome, it messes up the whole thing with some “exotic” bindings. I am fully aware that it is maintained by volunteers who can leave at any time, but it would be welcome if the relevant part/binding is then defined as “not maintained” or “dead”. Unfortunately, it looks like the length of the list of bindings is more important than tests of functionality here.
The 1.x irtrans binding works under OH1 without problems for me, but brings OH2 into an inoperative state every few days. I never really understood the concept of 2.x irtrans binding and never got it working.
Unfortunately, I am not a software person, but in my experience, this sooner or later puts every open source project into question!

I found this:
Maybe @kgoderis and @Kai can think about this.
Again, I think openHAB is a great solution and a great achievement, but if the target audience is the general public and not just “nerds” then such stumbling blocks are not exactly an advertisement for the product.

Thanks for your time and best regards,

Hi Klaus and everyone else in the thread,

I am late to enter the thread, but let first of all say that the irTrans binding is working in a 2.0 context. At least, it does on my hardware, which might not be on the latest firmware version of irTrans, or latest hardware iteration. That is because I never bothered to upgrade the irTrans devices, and thus, this is on 5y old hardware. It might be very well the case that the binding is not working correctly with newer versions of hardware/firmware.

For all completeness, it only works with hardware that has the on-board ir code database. Initially I tried to develop a binding that uses hex ir codes from openHAB but I abandoned that because of the many problems I had with the ir codes themselves.


Hi Karel,

thank you for your quick reply, and your work in the irTrans Binding. Maybe together we can sort out Christian’s and my problems?

I used an USB-irtrans device since 2008. Since 2015 mine is the “IRTrans LAN DBHF” and still with original firmware (LAN Version L2.06.27 and IR Version E6.10.10). As far as I know, there’s no new firmware since 2013. As I mentioned before, it worked without any Problems with the old OH1.9 and 1.9 binding. Using the WebIF of the device I can send commands, so the device itself is working. Using the old 1.9 binding with the OH2.x always results in OH crashes after 1 - 4 days (which might be related to java but not sure).

Being on the latest OH 2.5.7 (with Java Zulu 8 32-Bit OpenJDK) and like @KenkiCK, I tried the manual configuration and 1:1 as in your samples and also via the PaperUI. Always ending in Bridge being ONLINE and the Blaster in INITIALIZING status.
For me somewhat unclear are your output LEDs, I don’t use external LEDs, just the build in. So I tried I, I1, I2… and B, B1, B2… but no difference Blaster is in INITIALIZING.

Maybe you have an idea. Any hint, any advice is highly welcome.


Hi Karel,

from my point of view it makes no sense to publish a very restricted and limited binding in the standard binding package. It looks nice in the list of supported devices but it only suggest a support.

I am a big friend of Openhab but such “unsupported” bindings make it hard for newcomers and many give up very quickly. But a platform does not only live from the people who develop it but also from those who use it.

But this is a general discussion about how the community and the developers want to deal with it.

I can only recommend to everyone not to rely on the fact that if a binding is available then buy the appropriate device. Especially if they are rather exotic.

best, Christian

1 Like