Openhab2 Milight binding issue

recently I bought some milight RGBW bulbs and an Milight iBox2 Bridge for my room. I connected the Bridge to my Wifi network and was able to link the bulbs to different zones via the Mi-Light App for Android devices. Now I want to control the lights via my Amazon echo dot. Because of this I decided to use the Openhab2 Software. So I installed it on an old Laptop I had lying arround. After the installation of the Software I installed the Milight binding and started A search in the Things tap of the Paper UI. But the bridge was not found. I added a Thing manually by entering the IP adress of the Bridge and it shows a Milight bridge that is online. Then in my InBox multiple devices showed up (Color 1, White 1,…). After adding them and link them to an new Item, I went over to the Control panel, but whatever changes I made with the sliders nothing happend.

I searched a long time on the web, but could not find a solution for this problem.

I hope that you are able to help me to bind my Milight Bridge and bulbs correctly to the Openhab 2 Software.



Did you install the stable or unstable Version from OpenHab?

There is a new version from the MiLight Binding. Maybe this works better for you.

I installed the stable build and the Milight binding 2.0.0 not the 1.9.0 one.
Thanks for your answer I will try this later when I am back home.
Hope this will work:)

I now downloaded the .jar file to my linux laptop and then moved it to the folder under usr/share/openhab2/addons.
One time I extracted it, and the other time I didn’t. I restarted the Laptop but with the same effect. I was not able to find the Milight bridge via the search function, but i can manually add the Bridge via the IP Address. The Bridge is marked as online. But I am not able to control anything from the Control tab.

Hi guys,
I tried it again I completly uninstalled the openhab 2 software and reinstalled the latest stable version of it.
But again with the same result. Openhab does not find the Bridge automatically. I can add it manually as a Thing, but then when I move the Linked color slider arround nothing happens…

I hope that there is anybody who can help me!!!

Please try again with latest unstable version. Implementation of V6/7 protokoll is not included in stable.

I can confirm this issue. Milight binding is not working with iBox2. I have milight bridge v6. I seems to me tried everything…

  1. Installed stable version of OpenhHab (2.1)
  2. Installed snapshot versions of Openhab (2.2.0-SNAPSHOT)
  3. Installed stable and snapshot versions of milight bindings.

The binding can’t discover v6 bridge (however it can discover old v3 bridge). I added milight bridge manually, by specifying IP address if my bridge and its MAC address. I can see that bridge in the list of things, OH says it is “online”. However, when I add RGBWW ALL channel and try to control brightness or colour, it basically does nothing.

I can control my LED strip via that bridge and an android app, so it is working. However it does not work with OH milight binding.

I can’t see any errors in the OH console. There are some debug outputs likes that:

22:34:45.021 [DEBUG] [milight.internal.protocol.QueuedSend] - Sent packet '80 00 00 00 11 19 01 00 37 00 31 00 00 08 03 64 00 00 00 00 00 A0 ' to bridge
22:34:45.124 [DEBUG] [milight.internal.protocol.QueuedSend] - Sent packet '80 00 00 00 11 19 01 00 38 00 31 00 00 08 02 00 00 00 00 00 00 3B ' to bridge
22:34:46.526 [DEBUG] [milight.internal.protocol.QueuedSend] - Sent packet 'D0 00 00 00 02 19 01 ' to bridge

E.g. nothing suspicious.

What else I can check to troubleshoot? @hmerk @David_Graeff

Thank you for your help.

If it helps, I’ve got V1.0.08 bridge version.

The problem is : I’m visiting Sydney and there is no point for me in buying milights here rn, so I don’t have the physical devices to test with.

Someone else might need to take over the maintenance for the time being. Especially since the latest firmware of the milight seem to broke the binding indeed.


Eh… You’d better be visiting Auckland as I live here…

Would that help if I shared ssh access and probably installed a web cam for you? :slight_smile:

@David_Graeff ^^


Was in Auckland some time ago :stuck_out_tongue: yes a VPN would help, but I don’t have time rn as I’m adding mqtt bindings to eclipse smart home. oh is based on that.

Hello David,
I have installed the milight binding project in eclipse and make some changes arround the MilightV2RGB thing-type.
We have some old ledstrips installed in the house and i want to controlled them all from OpenHAB2.
With the changes i made you can switch the ledstrip on/off, increase-decrease brightness and animation speed, select mode up/down. In the eclipse environment everything is running perfect.
Next step is to export the binding to a xx.jar file and put this in the addons map of our total installation.
I have done this but after restart the openHAB2 nothing is happen.
Do you know how i can fix this ?
Kind regards

Did you already have the milight binding installed through the PaperUI? If so you might need to uninstall it.

If you login to the karaf console and type bundle:list do you see the milight binding listed twice?

Would be nice to share the changes to integrate them back to OH.


thanks for the replay…

Yes i have uninstalled the Milight binding by the PaperUI, and then put the jar-file in the addons map
Nothing happens…
Milight is not in the bundle list, so it looks that it do not recognice the milight jar file.

Is the name of the jar-file important ?

during the export to jar-file i received a warning : JAR export finished with warnings. See details for additional information.
org.openhab.binding.milight/META-INF/MANIFEST.MF was replaced by the generated MANIFEST.MF and is no longer in the JAR.
meaby this is the problem ?


Hello David,

OK yes, if everything is running, i will supply a small example and the src of this


Have you tried building by running “mvn install” from the milight binding directory?

I tried to do so (and of course deploying it to OH). No luck. Same result.

Hey Mike,
i have tryed to run the the ‘mvn -o clean install’ command, but i have an error;
Error initializing: org.eclipse.tycho.p2.resolver.P2DependencyResolver@56ac5c80
do i need to install something more in the eclipse?


Hey Mike,

Problem solved, building by running “mvn clean install”, again a step in the good direction :grinning:

thanks for the info…