Openhab2 Milight binding issue

Hi Vlad
what type of have you used to bind led strip controllers to ibox2? I’ve tried whiteLed, rgbwwLed with no luck so far.

The same issue occurred. I cannot use led strip controller on ibox2.

Please tell me how led strip controllers controls on openhab .


CC @David_Graeff

Hi, can someone please help me out with the mliight binding, I setup my v6 led bridge with my rgb light first which i was able to connect to openhab manually because auto discovery did not see it and after entering the v6 ip into the manual it picked up the rgb zone and my bulb worked with the sliders but i just added a dual white bulb to my bridge and it is not showing up on openhab auto discovery and I am a little nooby about the manual discovery as i just tried to go through the white option and put in the ip of the bridge but no luck.
Thanks in advance, Amit.

I need your help please - I am also trying to bind Milight with OH2 wo success so far. In Paper UI, I added the bridge (manually since discovery isn’t working), I specified the MAC, added Group 1 as thing and linked it to the bridge. All appear online, but moving the slider of Group 1 (or All) does nothing.
I see this problem was solved, but I didn’t understand the solution - sorry but i’m a beginner on this.
Could someone please explain the solution step by step?

@David_Graeff So I’ve also run into this problem of 8 Zones just now and found this thread which seems to have cooled down a bit. Have you found out anything so far regarding that issue?
Regards, Hammer

I developed the binding and v6 support but I do not own any of those bulbs or such a bridge. So I can’t help maintaining it or solve those issues unfortunately.

Cheers David

Hi everybody,
only to report that me too fall down the “unable to discovery” with V6 binde and tried to add it manually
First time nothing was running even with the bridge correctly on line status; only inerted IP address and MAC

Second time, yesterday night, after a fresh new install of 2.1 OH
Same steps but this time I ovveride the port 5987 in the bridge configuration, even if default value
Don’t know if this was relevant but now I got, (recently last night) all RGBWW bulbs working and the led bundled with the wi fi box too.
The Simple switch in the ssytem menu help me adding things and channels, like instructions said.

About discovering, I found out that the wifi led binde discover the new wi fi box bridge

I will continue discovering all the rest of OH2

Hi @David_Graeff
Thanks for your work. Very appreciated. I’m using iBox2. No problem with auto discovery. Binding seems to be linked correctly. Is there a way to control LED strip? I’m using two strip rf controller model FUT038. MiLight application is controlling that hardware through iBox2 but I’m unable to control it with the binding?

I don’t own an ibox so can’t help.

Cheers David

Hello Elenio,
I’m trying to make working my iBox2 with a FUT038 Led Controller. Nothing was working after few weeks of test. I did a lot of install, uninstall, stable version, snapshot… Name it I probably tried it :slight_smile: I just decided to gave it a try to your proposition to override port 5987. Magic, I can’t explain it, but colorpicker is now responding. I used all RGBW things, so all my led strip are now responding at the same time. I hope I will be able to modify it to separate channel and keep it working. Last thing to do will be to control the white led on the strip.
So thanks for your post, I now think this manipulation is relevant to answer your question.

1 Like

Finally, not able yet to control white LED. If someone have an idea what I could try, I’m open to all comment.

I also have another issue. I change to DEBUG mode the log to see further what happen and now I’m getting every second this line:

Is someone know what is this command (D0 00 00 00 02 4C 00), why it is sending to the bridge like this and how to stop that?


Update: I think I found the answer by myself. D0 00 00 00 02 4C 00 is a kind of heartbeat and frequency could be control by a parameter in Paper UI. See below. I change the parameter to 60 and restart MiLight bundle to get a single communication with the bridge once every minute. I hope this delay is not too long, I don’t want to cause any other problem.

Here try this
I also cannot control my white milight bulbs with openhab. I just use my white bulb as a normal led and I use my colored and white bulbs with openhab because they work but the white bulb is indifferent to any commands sent from openhab.
PS: everything works great (including) the white bulb through the milight app as long as you select the correct remote in the app.

Thanks. I have the exact same behavior with my strip LED controlled by FUT038 controller. I will wait about an update for the white led control. Following the link you sent me, the command should be [0x31,0,0,0x08,0x05,0x64,0,0,0,zoneID]; I don’t know if it’s possible to send a direct command to the MiLight bridge through the binding or by any other way?

I’m not sure either. But about the led strip I have a RGB milight
controller and it works through the rgbw part of the milight binding.

I just can’t get this binding working. Sorry, I’m a noob and trying everything to get it to work.
Bought the IBox2 and 4 RGBWW (FUT017) bulbs. With the mobile app it works ok.
If I try in OpenHab, I just can’t get it to work. Please help.

  • installed org.openhab.binding.milight-2.3.0-SNAPSHOT.jar
  • added manually the IBox2. It’s online and I get 11 things
  • connected things to some items, like a dimmer for brightness

Is it working out of the box, without linking to zones?
Or do I need to make a “Link” switch in O.H. to link a bulb to a zone? Just like the official app?
Or do I ‘link’ the bulbs to zones in the official app first, and then install the binding?
Or is it necessary to ‘unlink’ the bulbs in the official app, before using this binding?

If I use my selfmade dimmer item, it doesn’'t work.
It also doesn’t work if I try to ‘link’ the bulb (turn on the light and turn my selfmade ‘link’-switch to ON) .

If I look into the log file, I see:
[ome.event.ItemCommandEvent] - Item ‘MLBulb_overloop4’ received command ON
[WARN ] [nal.protocol.MilightV6SessionManager] - Command not confirmed: 18

What am I doing wrong?
Can someone please help me?

Is there really nobody who can help me getting these Milight RGBWW bulbs to work with this binding?

Sorry I don’t own a milight hub as I used an opensource one and wrote my own binding which is found linked below. I gave up waiting for Milight to release a hub that no longer has a 4 or 8 group limit. The opensource hub works great and supports all globes (AFAIK) and can still be used with the official Milight binding or you can use my binding which uses MQTT. I have 23 Milight globes all with individual control using the method in this link…

Thank you matt1 !
And where can I buy such a Opensource Hub?

Follow the links and where to buy and how to setup is all there. Hint you need to buy two ready made boards and connect the two, flash some code and your away. Anyone that can get openhab running will find it easy.

You need a bridge