openHAB2 piface setup

Hello together,

I have now tried to get openHAB2 running on my raspberry pi
Unfortunately I cannot get the piface binding showing up in the binding list.

What I tried so far:

  • Copied the org.openhab.binding.piface-1.8.1.jar file from my 1.X to the addons folder and changed the addons.cfg:
    The piface.cfg file was not created automatically (I created it manually)
    I copied the settings from the old openhab.cfg file (and removed the piface: in front of each setting).
    started openHAB (using
    Error messages I got so far:
    “No Piface node for id PI”
    (PI is the id I gave in the settings: …)
    (Item is also defined acordingly: Switch Garage_MoveDoor “Garagentor Start/Stop” (piface) { piface=“PI:OUT:0” } )

Then I tried to be more intelligent than usual and searched for SATEL binding as example - this is also an old binding)
Found it in the Y:\runtime\karaf\system\org\openhab\binding folder (I mapped it to my PC)
I tried to create a similar folder structure for the piface addon
and added the maven-metadata-local.xml
But I’m sure that this is not sufficient.

Then I found something about piface 1.9.0 binding, but cannot find a jar file and as a .NET developer I’m completely lost on what to do and how to compile the sources found.

So any input would be great.

Just a bit more background.
I’m currently running OH1.X and I’m happy with it (Except there is no KEBA binding I could get hold off and I do not get UDP working), so I wanted to switch over to OH2 where I have a KEBA binding, but now I do not get the PIFACE working.




The nightly 1.9 addons builds are on cloudbees:

You can download them all by clicking on the Last Successful Artifacts link, and extract the binding’s jar file from the zip file.

Thank you, meanwhile found it (by accident).
Seems to be hidden very carefully.
Anyway, I still didn’t get it to run unless I removed the complete installation (except for conf and addons folder) and replaced runtime and so on with a fresh copy.
Had to install all bindings and so again (unfortunately).
But after that, it started working.

I’m not quite sure if there shouldn’t be a kind of “rebuild” function included which recreates all the current settings again to get rid of any old “left overs” from other bindings which have been there but are not anymore.

So, this thread is the top result on Google for “openhab2 piface” - if you’re like me and have been using openhab1.6 forever and finally upgraded and wondered what’s going on, this is what I had to do to get piface up and running again (and also for me, when I forget and need to do it again…)

Assuming you’ve already got a working OpenHab2 install. Unsure if there are file location differences, but I installed via an apt repo and installed the “Expert” packages as per documentation:

  1. Get your RPI setup the same way as per
  2. Go here: click on Last Successful Artifacts link, download the zip file and then browse here: archive\bundles\binding\org.openhab.binding.piface\target
  3. Copy org.openhab.binding.piface-1.9.0-SNAPSHOT.jar to /usr/share/openhab2/addons - OpenHab2 will automatically load the file into runtime
  4. Create /etc/openhab2/services/piface.cfg with required piface configuration. Base copy listed under “Binding Configuration” here:
  5. Create your items as required in /etc/openhab2/items


1 Like

I can confirm that this addon works without any issues in openhab2.
So maybe someone can add it to the distribution? I mean the list of bindings in the paper UI.

I’m not sure who the right person to tag is so I recommend starting a new thread with a link to this one entitled: “piface binding works on OH 2.0”. The right person or people should see it and it will get added to the distro.

Please someone open an issue here to request that this binding is made installable on OH2. That way this good news and request won’t get lost. Thank you!

1 Like

Annndddd done:

@rlkoshak you could probably delete that other post since it’s now redundant (doesn’t look like I can do it myself)?

I don’t have that power. You can edit it and just say “never mind”.

1 Like

I have a question regarding the PIFace configutation. What IP address is required here?

IP address of my network?

That’s the IP Address of the RPI running the PiFace board.

Ok. I just spent all night on this. I followed all the steps in this thread AFTER I made sure my RPI3 and the piface were talking. That part works.

I copied the org.openhab.binding.piface-1.10.0-SNAPSHOT file to the /usr/share/openhab2/addons folder and updated the owner, I added the piface binding section to a piface.cfg file in the /etc/openhab2/services folder and updated the ownership. Updated Java to the 1.8.0_131 and rebooted. did several update && upgrades in there too.

Openhab looks just like it did before I did any of that. What did I miss?

By now, I hope I’m close. Thank you for all of this and for any help.

Digging around I found this:

!ENTRY org.openhab.binding.piface 4 0 2017-05-06 07:20:35.532
!MESSAGE FrameworkEvent ERROR
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.piface [193]
Unresolved requirement: Import-Package: org.openhab.core.binding

at org.eclipse.osgi.container.Module.start(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(
at org.eclipse.osgi.framework.eventmgr.EventManager$

Is this a java error or did I miss a piece?

@rxmas I’m not 100% sure, but when I wrote the instructions 1.9.0 was the version to use. 1.10.0 might be the version that automatically integrates with OpenHab2, so these instructions might have changed.

Would suggest trying the 1.9.0 snapshot version of the PiFace binding, or upgrading your whole OpenHab install nightly/beta?

Thank you for the quick reply. I went back and looked for the 1.9.0 version but didn’t find it and I’m not sure how to upgrade to the nightly but would be willing to try either / both. I’ll keep looking and will let you know if I do anything else.

@rxmas there’s potentially a mirror here?

I’ve also put the version I’m using here if you can’t get that one to work.

Thank you! I’ll give it a try


I’m starting over. I have a fresh install of Raspian and the piface is working as stand alone devices. I installed Openhab2 and in the PaperUI added the bindings for Piface. Nothing. I added the bindings for ‘network’ and instantly got a list of everything in my network.
If the GPIO biundings work, I’m thinking I should dump the Piface and just control an external board of relays, AKA admit defeat…

I Have one question to the PiFace config, too:
I want to use my RPI (Openhab2.4+PiFace digital2) without a network after installation,
what IP adress do I use for the piface.config?
I tried, localhost, “hostname” and even setup a static IP in the “dhcpcd.conf” file and used that one. Doesn’t work. Only works with the Real network adress.