Openhab2 stable debian 10 MQTT Broker configuration

Tags: #<Tag:0x00007f2fb4d18428>
  • Platform information:
    • Hardware: intel amd64 i3/8gb/120 gb ssd
    • OS: debian 10
    • Java Runtime Environment: zulu 8
    • openHAB version: 2.4 stable
  • Issue of the topic: i want to configure mqtt broker. mqtt binding installed. how can i do that??? i am using mosquito broker. i can control my devices via mqtt explorer.

What have you tried? I assume you already looked at the official documentation.

i want to communicate with mqtt broker. but i cant find any interface for mqtt broker config. i am using paper ui.

  1. i clicked plus sign in inbox.
  2. Inbox > Choose Binding: i clicked mqtt binding. search but nothing found.
  3. Inbox > MQTT Binding > Search: i clicked Manually Add Thing.
  4. Inbox > MQTT Binding > Choose Thing: i clicked Generic MQTT Thing.
  5. Configure Generic MQTT Thing: i saw name, thing id, location and bridge selection. i clicked create bridge. after that it is return to step 5. there is a loop. i cant reach to bridge configuration page.
    please some help…

There are 2 MQTT bindings currently in use. Some people find the older version 1 binding more feature-complete.
I do not use MQTT so I cannot help further.

1 Like

Have look into this documentation page.

@opus, I’ve reviewed that page. from that page: All things require a configured broker. but how can i configure the broker???

When configuring the binding via PaperUI ( and when having the mosquito broker setup and running) you initially need a mqtt broker thing ( which will act as a bridge between the mosquito broker and openHAB). The needed settings of that broker thing should be of no problem (you have the mosquito settings done ). This broker thing does not need any channel.
After that you can select that broker thing as the bridge for your generic mqtt thing.and do all other settings as on the documentation page.

I think my mosquito settings done, because I control my devices via mqtt explorer. I can’t configure or add that broker thing. I can’t find anything about adding broker thing. Can u explain me how to add broker thing?

Read The blog.
On PaperUI click the plus-sign in the inbox and select the MQTT BINDING. Select the manual add of things and select MQTT Broker (read the line under the title!).

There is no MQTT Broker on my screen!!!

What selections do you see?
Did you scroll down?

Generic MQTT thing
Homeassistant
Homie

I saw broker option on internet but I don’t have that option.

You previous said you have mosquitto settings done. Well, mosquitto IS your broker then.

You need to add the openhab mqtt binding, (look under addons/bindings in paperUI)
Then you need to add your mqtt thing. Either add it as a Generic mqtt thing through PaperUI, or use a manually created .thing file.

Thats the procedure… I have just gone though all of it today for the first time… I use a .thing file though…

My mosquito working fine, because I control all my devices via mqtt explorer.
Please check out my second post. Where should I enter my broker settings? I think create bridge. But is not working on my situation.

I have to ask again, when seeing those options, did you try to scroll down? The MQTT Broker Option is rigth unser Homie!

there is no mqtt broker option. please check out screen shot.

i had saw broker option on some video but i dont have it. have can i add mqtt broker option?

I am using Mosquitto as my MQTT broker, hence I haven’t seen how the use of Embedded MQTT Broker effects the binding. It MIGHT be possible that the MQTT BRoker Thing isn’t needed when using the Embeded Broker and the selction Option for such ins’t shown, BUT I AM NOT SURE ON THAT.

I am using Mosquitto as my MQTT broker too. I am not using the Embeded Broker.

Try to Install addons–>misc --> MQTT Broker moquette. Ist it now possible to choose MQTT Broker from add New manually menu ?