OpenHAB2 with multiple VLANs?

I’m just getting started with OpenHAB2. I seem to have everything running - I can get the weather!
Now I’m trying to integrate the things in my house - Nest, Harmony remote, etc.
The issue (I think) I’m running into if that all of my wireless devices are on a different network. For instance, my wired network (where OpenHAB lives) is 192.168.1.x, and my wireless network (With Nest, Harmony and several other devices) are on 192.168.100.x
For testing purposes, these networks are fully routed. there is no firewall involved.

How do you configure OpenHAB in an environment with more than one internal network? I hope I’m missing something simple! But I’ve looked through every bit of documentation I can find, and have so far drawn dead…

1 Like

Are you having trouble using the automatic discovery? I believe some /most for the discovery uses UPnP ( and that requires UDP. Your network would need to support UDP across VLans. This would not be a typical setup…

For any of the addons I use, they would still work with manual configuration. i.e. I would manually add the thing and enter the IP address, and then add-on would take over from there.

You are likely going to have a rough time with two networks. I ran my HA software in the cloud but made sure to bridge it into my home network instead of routing it just so I don’t have to try to work around the multicast, upnp, bonjour, etc type problems.

If you want it to work you’ll probably need some “helper” software to get the traffic across your networks.

Why don’t you divide your network into logical VLAN’s instead of just wireless/wired? For example, I have a special ‘smart home’ network where all smart home devices (including OpenHAB) reside. It includes both wired and wireless devices.

Then I have an ‘unsafe’ network where devices such as my TV and other non-controlled device are and a ‘safe’ network for my computer, NAS, mobile phone, etc. This last one has a WPA2 enterprise WiFi setup.

I can go from my safe network to my smart home and from my smart home to the unsafe, but not vice versa. For now this seems best working for me.

My experience is that many smart home devices are not ready for split networks. They somehow always assume people have just one network. Nowadays however this happens less and less, while probably the majority still have just one network.

1 Like

Thanks for the advice. @david - I have UPnP disabled across my networks for security reasons. I’ll have to give some thought to enabling it for this purpose.

@Dennis1984120 - I have 7 networks currently for the reasons you outlined. I keep the wireless clients, wireless and wired cameras, management, media, logging and automation stuff separated from the trusted network. It seems I may have to move the OpenHAB server to the automation network to make this work without introducing UPnP. Unfortunately, that will create problems when I start to integrate other systems. For instance, I can put OpenHAB in the same network as the Nest and Harmony, but then I’ll have to route to get OH to the BlueIris server on the surveillance LAN. I agree that most of these devices are not ready for a segmented network, which is a bit disappointing. I understand the draw of UPnP and cloud-based outbound-only services for general ease of use, but I wish we could still go back to full manual configuration. the Harmony module, for instance, would be great if I could just type in the IP address of the hub!

I have much to learn…

For some of the devices it won’t matter. For example, openHAB communicates with my Ecobee thermostats (and I assume the same for your Nest) through the Ecobee servers, not direct. The Harmony remote, on the other hand, is local communication. I have solved the issue by running two openHAB instances. The main instance runs on a Raspberry Pi in my DMZ because it is accessible from outside my network. For local-only devices (in my case, Harmony Remote, Sonos, and SNMP), I also run an internal instances of openHAB. I tie the two instances together via a mqtt server that is also in my DMZ. mqtt is fast enough that any delay is negligible, and I find it easier than having to create a ton of firewall rules to allow certain traffic to the external openHAB instance.

@j_wittenzellner - I may have to try that later. This is new enough right now that managing 2 instances is a little too much… I did move OH to the automation network this morning, and it immediately picked up the Harmony, Rokus, and a number of other devices. I’m not forwarding UDP in my core router (ERS5530), and it seems that that is preventing any kind of discovery. It would be great to be able to define internal networks in OpenHAB that can be referenced by any plugin that needs to scan for things. Meantime, the server is accomplishing work. Now I can move on to creating automation and panels!

I wonder, if I move OH back to the original network now that it has found the things on the automation VLAN, if they would still work?? I may have to try that too…

Thanks everyone!

1 Like

Just for reference, the internal OH instance is very lightweight and probably only took a few hours to setup. All item states, etc. are transmitted via the MQTT event bus, so I did not have to bother setting up a bunch of MQTT items. All rules, etc. are run on the external OH instance, so there isn’t much administration to be done on the internal instance.

Hi. I too struggle with VLAN UDP broadcasts that are not recognized by OpenHab if OpenHab is on the LAN side. They are received (I checked with wireshark) but Openhab does not see them.
(see post: Doorbird video doorbell binding )

Have you found a solution to your problem in the meantime?

A small note - Docker deployments do behave differently than normal ones. If you do not attach container properly UDP packets will not reach OH.