OpenHAB2 Z-wave - DO NOT use PaperUI

Please do not use PaperUI to configure the Z-Wave binding - doing so could result in a hard reset on your stick which would result in loss of your network.

I’ll remove all this functionality from the binding until this gets resolved but for now, I don’t recommend doing configuration of a-wave things with PaperUI.

Chris

Chris,

I assume this is due to tha action buttons right. Remember I had the same issue when I implemented them in the MAX! binding, workaround was fairly easy, setting the default values and ensure to not write the hard-reset value to the configuration. Maybe that would work for you as well

Right, this is similar to what I also suggested to Chris here: https://github.com/openhab/openhab2-addons/issues/693

Yes - something similar to this is now implemented in both HABmin and Z-Wave. In the Z-Wave binding I check for a specific value, and in HABmin, it’s been changed so that it sends the default value, which can the be set in the config descriptions.

This was implemented yesterday so should now be in the binding, so it should be safe again :wink: