OpenHAB3 / OH3 / Netatmo Internal Station Temperature State Presentation Decimals

  • Platform information:
    • Hardware: MacBookPro15 8Gb Ram
    • OS: 10.3.16
    • Java Runtime Environment: 11
    • openHAB version: 3.0

I am returning on the issue as I have tried all that can be tried in my knowledge without any solution. I keep getting the 10 decimals in my sensor’s temperature reading whatever I do.

I have set up a Metadata “State Presentation” at item level specifying that it is a read-only and

[%.1f °C]

in the “pattern” line.

In the UI the YAML Code is

component: oh-label-card
config:
  title: Temperatura Salone
  item: MainIndoorStation_Temperature
  pattern: "%.1f °C"
  fontSize: "25"
  fontWeight: Normal
  icon: oh:temperature
  iconSize: 30
  trendItem: MainIndoorStation_Temperature
  footer: Netatmo Sensore Interno
  iconUseState: true
slots: null

OpenHAB 3.0 does not allow me to code the item from the UI so I have no idea on how and where to put the

Number Livingroom_Temperature "Temperature [%.1f °C]"

Specified in the Wiki.

Any help would be highly appreciated.

I’m pretty sure you don’t include the [] in the metadata.

Hi Rich,

it doesn’t work neither with the [] nor without.