OpenHab3 &

  • Platform information:
    • Hardware: RaspBerry PI model B Rev
    • OS: Raspbian GNU/Linux 10 (Buster)
      Linux 5.10.17 +
    • Java Runtime Environment: Zulu11.45+27-CA (Build 11.0.10+9-LTS)
    • Java client VM Zulu11.45+27-CA (build 11.0.10+9-LTS, mixed mode
    • openHAB version: 3.0.1 - release build
  • Issue of the topic: I’ve an addon board (RazBerry2) to support the ZWave devices. OpenHab3 is apparently not able to direct communicate with this addon via the zwave binding. Using this way the device is mentioning that is is down. I use the port /dev/ttyAMA0.
    When using the Z-Way binding then it is able to communicate. When adding the bridge zWave devices can be added however the status of those are reported as offline while they are still acting on command from OpenHab3. Another issue is that scanning the ZWave binding in the list a second bridge is appearing So I’m wondering if this is normal.

As I understood the following need to be done to be able to work with ZWave:

  1. Add the Z-Way binding
  2. Add the bridge
  3. adding the ZWave devices

But after the second step a new bridge is added. Is this normal?

So two questions:

  1. Can RazBerry2 direct work on OpenHab3 without installing the
    wget -q -O - | sudo bash
  2. Is it normal when using the z-way binding that a second bridge is appearing after a bridge is added.


Why not use the zwave binding?

that’s just the issue. I’m not able to control the Razberry with the zway binding and that’s the reason I’m using the z-way binding.
However with the z-way binding there is a strange behaviour.
When the Z-way server bridge is added and I scan for devices as a result I got:

I assume that the Z-Way server with IP address the server is on internet and the second one with IP is the local server as it is the address of the OpenHab device.
The device Rolluik_Garage (Goap) is the Zwave device connected to the Razberry controller.

Another issue is that the device (Rolluik_Garage) is offline while the switch channel is working but the blind channel is not working

When I disable the device in Things and enable it again, it is coming online for a short period of time.

Thanks for the help

Not a lot of reactions over here.

Other question to use the Razberry setup board on Raspberry with openhab3 do I need to install the environment via this command:

wget -q -O - | sudo bash

Or can Razberry setup board work directly with the z-way binding. If the last is correct what passwd do I need to use in the bridge configuration.

I think that the reason why you don’t get a lot of reaction is that not a lot of people use z-way binding. The way to control the your razberry with openhab is explained here and is still good for a pi 4.

I’ve restart from scratch and downloaded the image for Raspberry. installed the sd card and powered the rasberry. After a while OpenHab3 has been installed. Then I launched the command

sudo openhabion-config

select ‘System setting’ > serial port > Prepare serial ports for peripherals like Razberry, SCC, Pine64 ZWave, … > Disable serial console.
After this installed the zwave binding and the zwave bridge and I was able to add devices and control them. So actually you don’t need to install the
The Razberry is working with the zwave binding and doesn’t need the zway binding.

So this item will be closed