Openhabcloud problem after migration from 2.5.10 to 3.0.0

Hi guys,

I have taken the christmas days to make the switch from 2.5.10 to 3.0.0.

I am running on a QNAP Docker built system with Zulu zulu-openjdk:11.0.9 running as Java. So far all things are under control. The only thing that I am very confused of and do not know where to look is openhab cloud on mobile.

I am running on iOS and have the publicly available version as well as the beta version through Testflight. With both versions it is the same that I do see the basicui (the old one) when connected locally. As soon as I switch to the mobile network, all is blank. No sitemaps to choose from nothing. I checked if it is a myopenhab problem and connected through the web service on my computer’s browser. Here is all worked, I have access to the pages and can use it.

Does anybody know where I can look to get things running again ? According to DEBUG logs from …openhabcloud.internal.CloudClient requests get to the system when running the iOS mobile application on a mobile network but nothing is shown at all. No new or old UI and nothing that I can setup anywhere.

Any clue where I could look at is highly appreciated.



I believe the UI pages are mobile friendly. Have you tried the browser on your mobile device?

Yes, that works without any problem. The pages are shown within on the mobile web browser.

I just do not know why even the old layout is not shown when I log onto the service through the iOS application. Within the exact application locally I get the old basicui view. Outside the network it is blank.

1 Like

With the newest Testflight version of iOS it started working again. Thank you to whoever fixed this bug.