Openhabian 1.2 PINE64 hangs after reboot

Hi all
I’m finding this strange behaviour. Steps:

  • Downloaded openhabian 1.23 image for PINE64, decompressed and created a 32 GB SD Card using Win32DiskImager. Decompressed image file: openhabianpine64-xenial-20170317-git5125a3d-crcab2f3232.img
  • First boot of the PINE64, wait a lot (more than 5/6h). Ok I can find the PINE on the net, openhab ready on 8080.
  • Configured Openhab for complete environment and wait
  • Ok openhab responds and i can install a few binding (eg: http)
  • Conntect to PINE using ssh (putty)
  • Issue the command “sudo reboot” (or you can power cycle)

The PINE will never return visible on the net, The leds on the LAN plug remain off.

If I restart the steps I always get the same behaviour: first bott and installation ok, hang after a reboot.

My PINE is a card only (2GB ram) and hasn’t WiFi i/f, cam or touch screen; is connected through LAN.

How I can grab information to support the troubleshooting ?
Thanks a lot

Is there any message on the console? Also see if it hangs with the network cable disconnected. A while ago (before OpenHabian) the Pine would wait a really long time trying to get an IP address.

Hey @fulvio_spelta,
this sounds like a rather tricky problem with hundreds of possible reasons. You should probably try a fresh setup and direct reboot to rule out a few reasons. Also please check this existing issue:

Thanks for the hint.
Currently, due to the need to have OpenHab live in my house (that is fully OpenHab managed) I’ve used without problems a Raspberry PI3 and OpenHabIan.

I’ll perform some test on the PINE64 as soon as I can and will update this post; at first I’ll try to connect a serial console.

About the issue regarding the HDMI, I’m using an headless configuration. To be completed I’m using a basic (without WiFI nor camera nor lcd/HDMI) 2GB board.
Thanks again

@fulvio_spelta I am experiencing exactly the same issues you are describing. Do you have any news about this issue?

First I thought I have messed up something but it’s looking more like a strange bug.
First boot will always work perfect but next one always fails. Have tried several “reboot” ways after installing, all resulting in a non-bootable state.

  1. Entering command: shutdown now followed by hard reset with power.
  2. Hard reset with power directly
  3. Using reset button on board. (Should be same as nr. 2)

Have used latest Openhabian release v1.3 and nightly by building last commit.
Other Ubuntu images I used have worked with no errors like this so far.


Pine64 2GB, no addon at all like WiFi / BT

Revision info: (sticker on back)
A64-DB-V1.1 2G
C160358 04.10

Hey Elias,
did you have HDMI connected?
Interesting that you did your own git build. The last time I’ve built a new image is a few months ago and i can not guarantee that the build still works.
openHABian is basically the longsleep Ubuntu with some modifications. No clue why the one would create an issue while the other doesn’t. Maybe because of one of the first start actions… would you be willing to test?

Sorry, no news, because i’ve switched to raspberry pi 3 due to the reboot problem using pine64.

Hi Thomas.
After I posted I have put some effort into solving the issue but with no luck. Have been traveling lately so this problem have been put a side. Anyhow to clearify the last testing round.

Used officially built images from the releases on github, specific 1.2 and 1.3. Also built latest from source

Tested with first boot with HDMI plugged in and without HDMI plugged in, same symtom no difference.

Lastly I checked the longsleep image which could be found over here and it worked flawlessly.
Longsleep image Is this the correct image which openhabian uses?

I can do some additional testing but don’t know where to start really. As the pine is stuck on boot its hard to know what its wrong. I wonder if there is possble to attatch a serial console or simular to the board to get some debug info. To be honest I don’t have so much time the upcoming weeks though.

I have something similar on Openhab 2.2.

When I turn of the Pine64, I need to wait at least a few minutes before it can boot again.
So calling reboot does not work.
Sometimes I have to try a few times before the device boots again…