Openhabian 2.0 Migration from Openhab 1.6


I’m currently trying to migrate my old config from Openhab 1.6 to Openhabian 2.0.
I bought a new Raspberry Pi 3 und installed the brand new release of Openhabian 2.0.

All worked fine. Sitemap is up and running und my zwave devices are already working.
But I have a problem with my homematic-Binding.
I use the compatibility-layer for 1.x versions und use the 1.9 homematic binding.
Homegear seems to be working correctly, because I can see all my devices
when running “homegear -r”.

But when I change the state of a switch I get the message:

[ERROR] [l.communicator.HomematicCommunicator] - -100 No answer from device. (sending BinRpcRequest[methodName=setValue,args={LEQ1227488:1,STATE,true}])

Can anyone help me out of this problem?

Thanks a lot,

That is only necessary for 1.x bindings which are not part of openHAB2 yet.
Homematic is already part of openHAB2:

But I doubt that could cause the error.

Is it possible to use both bindigs?
Or do I have to deactivate the 1.9 binding before testing version 2?

Two bindings for the same hardware at the same time won’t work.

And what’s the best way to test version 2?
Is it enough to install/uninstall the binding via paper UI? Or will I lose my configs for binding 1.9?

I guess it is the same as for all other 1.x bindings (sorry, I don’t use homematic): config for 1.x binding is stored in homematic.cfg, config for 2.x bindings is stored in JsonDB.
That means, if you uninstall the 1.x binding it will not remove the homematic.cfg.
Just in case, make a backup of that file before uninstalling the binding :grin:

If you are unsure what to do read:

I’m using the Homematic Lan-Adapter HM-LAN-CFG.
Is there any known compatibility issue with this device and homematic 1.9??


Everything works fine now.
I just had to wait some more hours for some reason.

When I came back home tonight, everything worked with binding 1.9.

Thanks for the help,

1 Like