Openhabian 3, myOpenhab

  • Platform information:
    • Hardware: Raspberry pi 3
    • OS: openhabian
    • Java Runtime Environment: openjdk version “11.0.9” 2020-10-20 LTS
    • openHAB version: 3.0
  • Issue of the topic: myOpenhab saying: Your openHAB is not online

Hi All,

After I create an account on myOpenhab, insert the correct UUID and SECRET, the site is still giving the message that my device is offline. (I waited for an hour to be sure that it is not an sync issue).

anyone an idea what could be the problem?

thanks in advance,


Wrong Java, seems you are not using Zulu 11…

Ok, I will try to install zulu 11

After that I will let know if this was the solution

Well not necessarily. Zulu is preferred yes but it might work with openjdk
But to install this is big nonsense when you’re on openHABian.
Clearly you have not read the docs so do that first, and please mind all the other items here as well.

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

I have read so many issues being solved after changing to Zulu, so I always recommend to change it.

At least for me, it didn’t solved the issue.

changed to zulu 11 (32 bits) but still no connection with myOpenhab

openjdk version “11.0.9” 2020-10-20 LTS
OpenJDK Runtime Environment Zulu11.43+88-CA (build 11.0.9+11-LTS)
OpenJDK Client VM Zulu11.43+88-CA (build 11.0.9+11-LTS, mixed mode)

Have you restarted once after entering the UUID and SECRET info??
You need to restart once and it will be online after that.