openHABian after 2.5.0 update: openhab isn't reachable

  • Platform information:
    • Hardware: RaspberryPi4 4GB
    • OS: Raspbian GNU/Linux 10 (buster)
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: openHAB 2.5.0-1 (Release Build)

Hi, i think i need some help (my linux knowledge isn’t the best :thinking:)

Since the upgrade to the latest stable openHAB release - following the instructions here - my openhab installation isn’t reachable anymore via browser and/or app.

The openHAB2 service is running:

sudo systemctl status openhab2.service
[sudo] password for openhabian:
● openhab2.service - openHAB 2 - empowering the smart home
   Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2019-12-21 14:47:41 CET; 14min ago
 Main PID: 531 (java)
    Tasks: 38 (limit: 4915)
   Memory: 202.7M
   CGroup: /system.slice/openhab2.service
           └─531 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.conf=/etc/openhab2 -Dopenhab

Any hint(s)/help is appreciated!

Did you try stopping and restarting openHAB?
I had to do that on one of my upgrades to get everything to load properly. I have heard of people needing 2 or 3 restarts.

Yes - i’ve restarted the raspberry multiple times, a system shutdown didn’t do the trick either…

Did you use the openhabian-config tool to upgrade?

If so try downgrading, uninstall restdocs, stopOH, clean the cache and restart OH. After everything has fully restarted (give it a few minuets) then go to the openhabian tool. Pick the first option, then the second and then third. After that go to “Apply improvements” (I think that’s the name) and run the first few e.g addition packages, fix permissions, ect…

After that exit the tool, restart OH and post any error you have in the logs.

Yes, i’ve used the openhabian-config tool to update.

Stopping openHAB, cleaning the cache and restart openHAB worked for me!

Thanks a lot & merry christmas!!!

1 Like

Glad you got it working and a merry Christmas to you as well.