openHABian and Static IP Address

1 Like

I faced almost same problem & problem resolved after fresh installation of Openhab 2.

I am not sure about why this problem arises in my previous setup, but it was started after enabling WIFI connection. So during fresh openhab setup I first applied statistic ip in dhcpd.conf file before doing anything else. & It works.

https://community.openhab.org/t/solved-how-to-set-static-ip-of-eth0-port/62974/2

I think there’s an error in the openhabian configuration when setting up static IP.

I eventually found my way out by following the steps described at StackExchange: How do I set up networking with static IP address

In essence, I had to replace /etc/network/interfaces/interfaces with /etc/network/interfaces/interfaces.dpkg-old, edit /boot/cmdline.txtand add net.ifnames=0 as boot parameter (to make sure your network interfaces are named eth0 and wlan0), and then add the following lines at the bottom of etc/dhcpcd.conf:

interface eth0
static ip_address=192.168.0.XX/24
static routers=192.168.0.1
static domain_name_servers=<dns.ip.addr.1> <dns.ip.addr.2>

Where xx represents the last byte of the static IPv4 address I want to assign to the wired Ethernet link (eth0 interface), and <dns.ip.addr.1> <dns.ip.addr.2> represents a space-separated list of IPv4 / IPv6 addresses of domain servers you should use (e.g., as provided by your ISP).

In my case I know I can pick any value for xx in the range 2 to 99 as those addresses are not assigned by the DHCP server of my cable modem/router. And I have to use static IP addresses as my modem/router doesn’t expose static address assignment.

Should you not know the names of your network interfaces, then please run ifconfig -a.

Hmmm, I am confused when reading all the articles about setting a static IP for Openhab. I also need to set a static IP and search for a simple and stable solution.

Is 2.4 now using stretch out not and
when I would use your recommendation will this be overwritten when updating OH?

Thanks a lot

To my knowledge there are 2 openhabian distributions available, one based on stretch (does not support RPi4), one based on buster (supports RPi4). The openhabian-config script will help you select the openHAB release you’d like to use, irrespective of the openhabian distribution. Right now, you can chose between:

  • openHAB 2.4 stable
  • openHAB 2.5 milestone (currently M4) — I’d recommend this for new deployments
  • openHAB daily snapshots — only use if you want/need to test new features or new binding updates

If your home automation setup is critical, I’d say to leave it at the current openHAB release and use a second computer (RPi) to prepare the migration to a newer openHAB version (based on 2.5 snapshot).

I haven’t tried upgrading a stretch-based image to buster; instead I reinstalled a blank buster-based openhabian distribution.

I did. Worked flawless.

Thanks a lot,

So I could solve the static IP issue for my OH2 2.4 on PI3b.

First:
I have edited the etc/dhcpcd.conf

interface wlan0
static ip_address=192.168.2.99/24
static routers=192.168.2.1
static domain_name_servers=192.168.2.1

restarted -> Not working

Second
I have edited additionally the /etc/network/interface file and just left that one line active:

source-directory /etc/network/interfaces.d

restarted -> BINGO works

Edit 02August2020
I updated to Pi4/Buster and I had exactly the same issue. It was required to follow the second step
and add/create the file and line /etc/network/interface. I think the file wasn´t existing and so
it was empty when using sudo nano /etc/network/interface.

2 Likes

It worked!