Openhabian & Bluetooth


I’m trying to get bluetooth working with the builtin bluetooth adapter on a Raspberry Pi 3 with the latest openhabian buiid (fresh install) and openhab milestone build (this is a dev machine)

I cannot get the Pi to recognise/see the bluetooth adapter. Both the hciuart and bluetooth services fail to start on a reboot and it’s not possible to start them manually.

HCIUART fails with the message

Condition: start condition failed at Mon 2021-11-01 16:01:42 GMT; 8min ago
           └─ ConditionFileNotEmpty=/proc/device-tree/soc/gpio@7e200000/bt_pins/brcm,pins was not met

and BLUETOOTH fails with the message

Nov 01 16:04:47 WGB01DEV1002 systemd[1]: Condition check resulted in Bluetooth service being skipped.

I have tried using openhabian-config to move bluetooth to mini UART which results in the message

2021-11-01_16:16:22_GMT [openHABian] Making Bluetooth use mini-UART... SKIPPED

Does anyone have any clear instructions on how to get this working?

Did you also tick the option 1 in the serial port menu ?
Use debugmode=maximum in /etc/openhabian.conf to produce hopefully useful output.

PS change the title please. Raspbian is not openHABian when it comes to details like these.

Title changed…

Yes, also ticked option 1 in the serial port menu.

I’ve set debugmode=maximum but don’t see anything different… Is there a log file somewhere I should be looking in?

Problem solved… Issue was purely human… Picked up the wrong Pi… Was using a Pi2 not a Pi3… Replaced with a Pi3 and as if by magic, bluetooth is now all working!!!

For info… setting debugmode=maximum hadn’t initially saved. Redid this and could see a lot more info… This led me to checking /proc/cpuinfo which is what told me I had picked up the wrong Pi and was using a Pi2 not a Pi3

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.