Openhabian cdc-acm driver not loaded for cc2531 Zigbee2Mqtt Dongle

when I plug in a Zigbee2Mqtt Dongle (cc2531) it does not show in /dev/tty…
In a different forum someone guided me to that point:

sudo lsmod|grep cdc_acm

I don’t get an answer, so the cdc_acm driver is not loaded.
How can I install that driver on my openhabian?

OpenHabian 2.4
Release = Raspbian GNU/Linux 9 (stretch)
Kernel = Linux 4.4.38-v7+
Platform = Raspberry Pi 3 Model B Rev 1.2

So, the firmware flashed dongle is not showing in the OS.
Please ask in the forum of the firmware vendor. Once you change the firmware from OEM. we have no reasonable way of assisting.

The custom flashed dongle not showing in the OS as /dev/tty has nothing to do with openHAB software.

I thought, it is about openhabian, as the driver is not in the kernel (I am not really that linux guy).
The Dongle is working, as I checked on a RPI4 under buster. Maybe the missing drivers can be installed somehow?

lsmod is checking what Linux OS kernel modules are loaded.
It is possible running insmod with the module name will load it or perhaps log some error to help.

Post an issue on the zigbee2mqtt gitHUB. Very helpful but you have to be patient

I tried to get an account there, but I don’t receive the confirmation email. I tried with 2 emails several times. So my account is not approved and I can’t create a new topic.

[22:05:30] openhabian@openHABianPi:~$ sudo lsmod
Module                  Size  Used by

So, a think no result???

insmod cdc_acm
insmod: ERROR: could not load module cdc_acm: No such file or directory

Maybe wrong directiory? or completly missing?

That would be my guess.

O.K., so how to get that in there?
(I thought these kind of drivers a native to liux, so to openhab)

OpenHAB has nothing to do with Linux. It is Java based and runs on Windows and MacOS too.
I guess that module is not installed by default on your version of Raspian.
You have not really told us what OS and version you are using.

Does the module name have a hyphen or underscore? You have used both at different times.

EDIT: perhaps this link can help?

In my first post. It is the Openhabian Image.

@mstormi I guess they are running your OS.

I give up for today. To tired.
Thanks for your help,
good night

What type of OS installation do you use (SD, flash or SSD drive)? I’am asking because also had problems with this stick on Raspbian Stretch (lite, full). System didn’t see stick when I used my Raspberry Pi3 B with OS installed on SSD drive. When I used flash stick everything work perfect. I tried different Raspbian versions (lite, full), and also on Raspberry Pi 2. The result was the same. So, as I understand drivers is not problem in this case. The most possible reason of such problem is lack of power, but I don’t have usb hub with external power to check it. Also the problem can be in conflict between SSD drive and 2531 stick. But it looks less realistic.
For me I solved this issue by using CC2531 on another Intel Atom based system with Ubuntu.

Good Point. The PI4 where it is working is on a USB-Stick (Sandisk), the Pi3 is on a SSD. I will check…
I put the OS on a Lexar USB-Stick and measured the Voltage on the Condensator just at the USB-Port of the PI.: 5.02V
After plugging in the CC2531 the Voltage is still on 5.02V.
The rest stays, the CC2531 does not show up.
Conclusion --> still the driver problem.

1 Like

Maybe there is a hardware conflict between ssd and CC 2531 stick. In order to be sure you can also install the same OS (as I understand openhabian) on SD card/USB flash and try it on the same PI.
As I already mention I tried several types of OS (even Raspberry Stretch lite) and all of them didn’t work with SSD and work perfectly with USB flash (both Pi3 and Pi2).

1 Like

I did copy the content of the SSD to a USB Stick (a wrote above ;)). Same result. What I did not test is to copy the content of the PI4s working OS to this SSD (as check if there is a problem with the SSD). Maybe this afternoon.

Did you solve the problem?

I got a Pi4 now and set up a complete openhabian for it. With this there is no problem. So, no I did not solve it, but it’s working now.