Openhabian-config : command not found

Possibly so. openhabian-config might be part of that or not. See if it’s installed and where:

[22:17:54] openhabian@openhabianpi:~$ sudo find / -name openhabian-config
[22:17:54] openhabian@openhabianpi:~$

openHABian is a separate tool to openHAB. You may want to consider running a openHABian image, or following the manual install instructions here to install it on top of your current OS.

I just ran an update (sudo openhabian-config) and “updating myself” finished without issues.
However, I get command not found since then even though I find it in the location posted by @mstormi above.

[13:19:14] openhabian@Homer:~$ sudo /usr/local/bin/openhabian-config
sudo: /usr/local/bin/openhabian-config: Kommando nicht gefunden
[13:19:44] openhabian@Homer:~$ sudo find / -name openhabian-config
[13:22:52] openhabian@Homer:~$ ls -la /usr/local/bin/openhabian-config
lrwxrwxrwx 1 root staff 35 Nov 14  2017 /usr/local/bin/openhabian-config -> /opt/openhabian/
[13:23:31] openhabian@Homer:~$ sudo /usr/local/bin/openhabian-config
sudo: /usr/local/bin/openhabian-config: Kommando nicht gefunden

I am running openHAB 2.4 stable on a Raspberry.

EDIT: Obviously disappeared…

The same Problem here. After Update i can’t start openhabian-config.

This was the Text after start the Update:
2019-03-20_11:45:34_CET [openHABian] Checking for root privileges… OK
2019-03-20_11:45:34_CET [openHABian] Loading configuration file ‘/etc/openhabian.conf’… OK
2019-03-20_11:45:34_CET [openHABian] openHABian configuration tool version: [master]v1.4.1-461(0cedba8)
2019-03-20_11:45:35_CET [openHABian] Checking for changes in origin… Updates available…
2019-03-20_11:45:43_CET [openHABian] Updating myself… OK - Commit history (oldest to newest):

c77da39 - Add CI pipeline with Java install func as demo (#547) (60 minutes ago) <Elias Gabrielsson> E
 .travis.yml                                    | 17 ++++++++++++++--                                | 87 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++-----------------
 Dockerfile                                     | 12 ++++++++++++                                      | 55 +++++++++++++++++++++++++++++++++++-----------------
 build-image/{ => first-boot.bash} | 53 ++++++++++++++++++++++++--------------------------
 build-image/openhabian.conf                    | 26 +++++++++++++++++++++++++
 build-image/rc.local                           |  5 +++--
 build-image/{ => webif.bash}           |  8 ++++++-- => build.bash                         | 46 +++++++++++++++++++++++++++++--------------
 docs/                             |  2 +-
 functions/                            |  4 ++--
 functions/{ => backup.bash}           |  0
 functions/{ => config.bash}           |  0
 functions/{ => ext-storage.bash} |  2 +-
 functions/{ => helpers.bash}         | 14 +++++++-------
 functions/helpers.bats                         | 14 ++++++++++++++
 functions/java-jre.bash                        | 68 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 functions/java-jre.bats                        | 18 +++++++++++++++++
 functions/                          | 70 ------------------------------------------------------------------
 functions/{ => menu.bash}               |  0
 functions/{ => nodejs-apps.bash} |  0
 functions/{ => openhab.bash}         |  2 +-
 functions/{ => openhabian.bash}   |  0
 functions/{ => packages.bash}       |  0
 functions/{ => passwords.bash}     |  0
 functions/{ => system.bash}           |  1 +
 functions/{ => wifi.bash}               |  0 => openhabian-setup.bash   |  2 +-
 test.bash                                      | 51 ++++++++++++++++++++++++++++++++++++++++++++++++
 29 files changed, 389 insertions(+), 168 deletions(-)

openHABian configuration tool successfully updated.
Visit the development repository for more details:
The tool will now restart to load the updates...

/opt/openhabian/functions/ line 77: /opt/openhabian/ No such file or directory

Did anyone have an Help?

I missed this part after the update - thanks.
So, this seems to work then instead of openhabian-config

sudo /opt/openhabian/openhabian-setup.bash

So this solved my issue finally:

[13:44:38] openhabian@Homer:~$ sudo rm /usr/local/bin/openhabian-config
[13:44:54] openhabian@Homer:~$ sudo ln -s /opt/openhabian/openhabian-setup.bash /usr/local/bin/openhabian-config

So i can start the tool again, thanks.
But how can this be adjusted again that the command openhabian-config works?

Edit: Oh thanks i am to late with my question.

Sorry for the breaking update.
Please run sudo /opt/openhabian/openhabian-setup.bash and apply the update.

After the update is complete you maybe need to run ln -sfn /opt/openhabian/ /usr/local/bin/openhabian-config as well if sudo openhabian-setup doesn’t work.

// EG


Still dosen’t work - command not found.

I’ve made full Ad. 1 and ad 2 update

I had the same issue, after

cd /opt/openhabian/
sudo ./openhabian-setup.bash

the config tool updated and works now as expected with

sudo openhabian-config

thanks for fixing.

1 Like


Try the steps Woogi made.
I should work, if not please come back with logs while running the commands.

I have already go ahead - just use sudo /opt/openhabian/ and install whole package in this way without making link too it.

It’s installed with mosquitto, java, grafana and influxdb - ready to use :slight_smile:

1 Like

@quarku Nice to hear :slight_smile:

As you may notice is the Grafana currently stuck on an older version. There will a patch for that coming up so stay tuned.

Didn’t know that - thank you Elias.

Have a nice day

For future googlers, this happens on a clean openhabian image but you have SSH’d in while the setup script is running.

You need to give openhabian a good 2 hours to finish it’s out of the box setup after first boot on the raspberry pi.
(Docs suggest up to 45 mins but mine too much longer)

What happens on which image ? The OP was “command not found”, @elias_gabrielsson’s most recent hint was on Grafana installation to get stuck (but the patch is available meanwhile), and you now report installation takes longer than announced but ultimately succeeds (which BTW isn’t normal either for the current version).
So what are you trying to tell us ?

I’m not reporting a fault - as explained above

For future googlers

because I didn’t RTFM and hit Openhabian-config : command not found because the first use setup script OpenHab runs was still executing when I ssh’d into it and tried to run sudo Openhabian-config.

and yes - the setup script took much longer than 45 mins on a Pi 3 Model B with SD of this profile

Writing speed: 43.5 MByte/s
Reading speed: 66.2 MByte/s
H2testw v1.4

I didn’t save the logs but if they are somewhere on disk I can pull them out if you want to see.


Thanks quarku!

This worked for me!

u a welcome :slight_smile: