Openhabian-config tool NOT pulling latest snapshot

I am running Openhabian on a Raspberry Pi3.

I am noticing the ZWave ThingTypeXmlProvider binding issue that has been discussed elsewhere on this forum, and I was told that that issue has been fixed in the latest v2.5.5 SNAPHOT build.

So I tried using the openhabian-config console tool menu command “update to latest snapshot”, but this command is NOT actually pulling the latest snapshot. I am expecting it to download a version called something like v2.5.5-xxx, but in fact it is pulling v2.5.4-1 which is NOT the latest snapshot. And if I try to repeat the update command again, the installer says “you are already on the latest snapshot (v2.5.4-1)”.

So I think there is an issue with this openhabian configuration console! Any ideas for a fix?

Not sure about an issue with openhabian tool but you can upgrade/downgrade with five easy commands.

From the doc’s:

sudo apt-get update
sudo apt-get upgrade

You may want to switch to a different repo, or an older (but more stable) version of openHAB. To do this, simply select the repo as in the installation instructions above, then find the version by bringing a list of all versions available to install:

sudo apt-get update
apt-cache showpkg openhab2

Once you know which version you want, you can upgrade/downgrade to it by using the apt-get install openhab2=[version] command, for example:

sudo apt-get install openhab2=2.1.0-1
#

Many thanks @H102 for the information, but unfortunately it did not help me.

I think the problem may be that the download link url for the 2.5.5-SNAPSHOT.zip file is broken or missing as far as the OpenHabian Pi configuration tool is concerned. Or something like that (??)

If you do the first 4 steps above and do not see the 2.5.5-snapshot as an option to select then maybe it’s the download link. If you do see the option then it’s something related to the openhabian tool.

Ok, I did what you suggested, and the 2.5.5-snapshot is NOT listed there as an option; indeed 2.5.5 is not mentioned at all; the highest version mentioned is 2.5.4-1

Ergo:

No there isn’t. There just is no snapshot newer than 2.5.4-1. See also this thread.

Are 2.5 snapshots no longer released nightly?

They never were. Only ever when there’s anything worth releasing.
And development moved over to the 3.0 branch, that’s why there’s just occasional 2.5 snapshots.

1 Like

There seem to be mixed messages, so I am confused: on one hand, they are advertising a v2.5.5-SNAPSHOT here https://www.openhab.org/download/ and I have been told to upgrade to that version, but on the other hand you guys are saying that no such snapshots exist. Which is correct?

Ant following a link. the snapshot was built 15 hours ago.

https://ci.openhab.org/view/Integration%20Builds%20(2.5.x)/job/openHAB-Distribution/

image

That’s a permanent advertisement. And very strictly speaking 2.5.4-1 is the latest 2.X snapshot.
Or to be precise, the latest that has been uploaded to the repo.
If there really was a 2.5.5-somedate as Bruce points out it’s probably just not in the repo (yet).

who told you?

1 Like

Were you told to upgrade openHAB to the latest snapshot or just one particular binding?

There is a script for upgrading the Z-Wave binding, for instance since the device database is part of the binding.

cdjackson and mhilbush ; https://github.com/openhab/openhab-core/issues/1445

I only want to upgrade the ZWave binding, and its respective database. => Can you let me know where is the script?

@benjy could you please look after the repo ? thanks

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

That snapshot is available on the apt/yum repo now.

Perfect. I confirm that openhabian-config is installing it now :slight_smile: