Openhabian First Installation Failure

  • Platform information:
    • Hardware: Rpi 3 B+/1Gb/ 16GB
    • OS: Openhabian 1.4.1
    • openHAB version: 2.4.0
  • Issue of the topic: First Installation stops always on Updating repositories and upgrading installed packages… after trail and fails more than 10 times. Internet connection is good enough and i see that the Rpi is downloading during the installation but at last it gives me failed.

I use openhab for more than 3 years and i did a lot of SD card installation,but i need to know if this time is a common issue with some other users or only me.

Thank you,

Hi Elie
You have tried the install 10 times? You said

but it really seems like the download is failing because the files don’t get downloaded. Not really an OpenHAB thing, more of a files not downloading thing for what ever reason.
Anhow, have you waited a little while? I think once a Pi has downloaded everything, it takes a little while to getting up and running (but no more then 10 or at the most 15 minutes)

Hello Andrew,

Actually i have a doubt it might be a problem from the internet connection noting that the connections fast enough to download 1 GB in 20 mins.

And yes i waited so long and at last it writes the the initial setup has been failed.
Anyway since no other member is facing this issue, probably the problem is local and not from the repositories.

Thank you,

I expect you checked, but do you have enough free space in the filesystem to install the files?

bad SD card?
Got a spare?

@Hollako have a look here. Most likely need a sleep in the

@mstormi Could this be caused by the change of the APT repo public key?

Unlikely for a new system (to have latest openhabian code).
Insert set -x into /opt/openhabian/build-image/ to get verbose output.

I can confirm that this is not a common issue. I just downloaded the image and did a successful installation.

@marcel_erkel, indeed it was my internet connection from the ISP, he was blocking some site or something. now it works well.

Thank you,

1 Like