openHABian: frontail log doesn't work & 21 leads to error

Tags: #<Tag:0x00007f433eb5a9e0> #<Tag:0x00007f433eb5a918>

Just found out, that my frontail log viewer doesn’t work anymore: http://OH3-IP:9001 leads to an timeout.
So I went into openhabian and chose 21 Log Viewer, but got an error

'There was an error or interruption during the execution of:
  "20 | Optional Components"

Please try again. If the error persists, please read /opt/openhabian/docs/openhabian-DEBUG.md or https://github.com/openhab/openhabian/blob/main/docs/openhabian-DEBUG.md how to proceed.'

In the log, openHABian says:

$ apt-get update
+ apt-get update
Hit:1 http://davesteele.github.io/comitup/repo comitup InRelease
Err:2 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
  403  Forbidden [IP: 3.125.168.216 443]
Hit:3 http://archive.raspberrypi.org/debian buster InRelease
Hit:4 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:5 https://deb.nodesource.com/node_14.x buster InRelease
Hit:6 https://openhab.jfrog.io/artifactory/openhab-linuxpkg stable InRelease
Reading package lists... Done
E: Failed to fetch https://dl.bintray.com/openhab/apt-repo2/dists/stable/InRelease  403  Forbidden [IP: 3.125.168.216 443]
E: The repository 'https://dl.bintray.com/openhab/apt-repo2 stable InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
+ return 100
+ echo 'FAILED (update apt lists)'
FAILED (update apt lists)
+ return 1
+ return 1
+ echo FAILED
FAILED
+ return 1
+ '[' 1 -ne 0 ']'
+ whiptail --msgbox 'There was an error or interruption during the execution of:\n  "20 | Optional Components"\n\nPlease try again. If the error persists, please read /opt/openhabian/docs/openhabian-DEBUG.md or https://github.com/openhab/openhabian/blob/main/docs/openhabian-DEBUG.md how to proceed.' 14 80
+ return 0
+ true
+ show_main_menu

So I guess, it has something to do with the move from bintray to artifactory…
But I updated to 3.0.2
as recommended here openHAB 3.0.2 Patch Release and the Sunset of Bintray

Do I need to change something for openHABian menues also?

I´m running Ubuntu Server and get exactly the same error. I think it could be the same problem as this APT Repo Public Key Expiration & Update - #15 by Benjy

This error means that the update ( local ) of the repo inventory failed.
This is because dl.bintray.com/openhab/apt-repo is not available any longer ( this was announced ).
A replacement for it is in place ( artifactory ). This one is already in your list ( Hit:6 ).
Because of one update failed the complete update failed.

=> remove the bintray entry in file(s) in /etc/apt/sources.list.d directory
=> then run the update again ( at least the above error should be gone then )

hmm…
my sources.lsit doesn’t have any bintray?

deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

there is a file /etc/apt/sources.list ( it looks like you checked that one ) and then there is a directory /etc/apt/sources.list.d/ with different files. Did you check the content of the files as well ?

Thanks, should have read your initial post more thorough… :wink:

but that’s strange, because I did upgrade to 3.0.2 in April, soon after Kai’s announcement…

[14:27:08] openhabian@openhabMain:~$ tail /etc/apt/sources.list.d/*.list
==> /etc/apt/sources.list.d/comitup.list <==
deb http://davesteele.github.io/comitup/repo comitup main

==> /etc/apt/sources.list.d/nodesource.list <==
deb https://deb.nodesource.com/node_14.x buster main
deb-src https://deb.nodesource.com/node_14.x buster main

==> /etc/apt/sources.list.d/openhab-linuxpkg.list <==
# Provided by the openhab Linux package.
# There are three repository types:
## - stable: contains the latest official release with tested features.
## - testing: contains new features that are currently in the testing phase (milestone and release candidates).
## - unstable: contains the latest changes which may be untested or have bugs.

deb https://openhab.jfrog.io/artifactory/openhab-linuxpkg stable main

==> /etc/apt/sources.list.d/openhab.list <==
deb https://dl.bintray.com/openhab/apt-repo2 stable main

==> /etc/apt/sources.list.d/raspi.list <==
deb http://archive.raspberrypi.org/debian/ buster main
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ buster main

==> /etc/apt/sources.list.d/vscode.list <==
### Disabled by raspberrypi-sys-mods ###

after replacing the sunsetted bintray I could (re)install my frontail log and now it works. (not orange anymore!)

1 Like