openHABian hassle-free openHAB Setup

Hello @Michael_Grossman, I’m not aware of any problems. In rare cases you might run into a time of interrupted network connectivity or some other unexpected problem. Please just retry once more.

Hi, Is it normal behavior of something is wrong as every restart the system re-installing and only install basic and paper UI. I also loosing bindings…

No that is not supposed to happen. You are possibly on a faulty build. Please remove and reinstall openHAB. The easiest way to do so would be to reinstall the openHABian image.

it’s a shame really - i have just reistalled everything from the previous set up due to SD card failure. i have tried to reinstall openhab but having the same issue. thanks

Your error description os pretty weird. Let’s hope that the next setup works better, otherwise, please provide more details. Ideally in a new thread as your problem does not sound openHABian specific.

##openHABian has finally reached v1.0! :tada: :fireworks: :tada:

Quite a lot has changed since the last version (v0.9). Check the list of updates or the commit history to get an idea. The release of version 1.0 is less related to new breaking changes and more related to two developments:

What now?

You already have openHABian installed on your system? You should be okay. :wink: However you could just as well update, bringing you many small customizations and improvements. Do the following:

  1. Execute sudo openhabian-config
  2. Select “Update” and watch while openHABian fetches all latest commits. Reenter openhabian-config and you might see a few more options to choose from.
  3. Select “Basic Setup” to apply a few improvements like vim customizations, user permissions or a nicer MotD.
  4. Explore the menu… :slight_smile:

Pay attention to the fact, that there is now a new image file available, in case you want to reinstall openHABian.

New to openHABian?

Soon you will find detailed instructions at docs.openhab.org. Till then, just follow the instructions here and be sure to check the update postings.

Not on a RPi

No problem. openHABian is a collection of scripts you can also execute on other debian based linux systems.
Warning: You may run into not yet known problems - this is a quite new idea :wink:

# install git
sudo apt-get update
sudo apt-get install git

# get openHABian
cd /opt
sudo git clone https://github.com/openhab/openhabian.git
cd openhabian

# Execute as root
sudo /opt/openhabian/openhabian-setup.sh

Changelog

Since the last update there have been a few improvements, the most important one:

Serial Port Extensions for Razberry, Enocean and others: After long discussions and with the help of a few, the “Serial Port” option in the openhabian-config menu is now way more powerful. Add-on board for the RPi (incl. RPi3) should now be no problem anymore. Sending out a note to @skeal @Skalleno @Branden_Smale @jaydee73

Many bugfixes: Please check the commit list for details. Dozens of details have been improves.

7 Likes

That’s awesome news Thom! Congrats on making it all happen.
A natural step forward after making it all official would be a dedicated category for openHABian. Wouldn’t you agree? :slight_smile:

Again, great progress! Looking forward to play around with the updates:)
Cheers!

I would agree and yes, we are already talking about it :wink: I’m not sure if openHABian should receive a category or if the already available tag openhabian is enough/better… Maybe a mixture of both even…

Hi Fredrik, are you aware of this website?
http://berryboot.alexgoldcheidt.com/images/

Here you can request ‘custom’ made BerryBoot OS Images. I would be interested in using it, let me know if you need me to test it when available.

@ThomDietrich: Yesterday I updated your script to 1.0 (Update & Basic-Setup) and this night I got the following CRON email from :

> Cron <root@openHABianPi> /opt/FireMotD/FireMotD -S &>/dev/null

with the text:

/opt/FireMotD/FireMotD: Permission denied

Have I missed something during update?

Hey @Fredrik, Hey @Maurits28,
I like the idea to have an easy way to install openHABian to an external storage (seems to me the interesting benefit of Berryboot). I’ve checked the instructions on how to prepare an image for Berryboot, I’m however not sure if openHABian is compatible to these instructions as it is not an image of the end system.
Would one of you be interested to make a few tests and see what’s needed?

Hi, is this image configured to access the new openHAB Cloud service i.e. is it possible to install and configure the openHAB Cloud Connector bundle on the local openHAB runtime?

openHABian installs the newest openHAB 2 snapshot build following the guide here. So: No, nothing is pre-configured but Yes, you can set up openHAB Cloud just as it is described in the instructions :wink:

Thanks!

Hey @jaydee73 thanks for making me aware of this error. No it’s not your fault. The script was missing the execution bit. I’ve fixed that. Please execute Update and Basic Setup.

Hello. This is all very new to me so apologies if I am raising this issue in the wrong place. Whilst running the installer, it fails when retrieving libgcc1 with the error message:

wget: can’t connect to remote host (93.93.131.18) Connection timed out.
E: Couldn’t download pool/main/g/gcc-4.9/libgcc1_4.9.2-10_armhf.deb".

Other packages seem to download successfully before this point. I can also successfully ping the 93.93.131.18 address from the Pi. Am I missing something?

Any advice would be much appreciated. Thank you.

Hello, this error is not normal. Were you able to connect via SSH? Please check the note on “What is a successful installation” here: openHABian hassle-free openHAB Setup

This shouldn’t happen. Please start anew.

Many thanks for your response Thom. I have tried again a few times now using a fresh copy of the image each time. The furthest I have got is the retrieval of “multiarch-support” but then I get the same host time-out message. The whole installation process restarts automatically 10 seconds after the error so I can’t SSH into the Pi if that’s what you mean. I have disconnected everything else from my network to remove any other traffic but it seems to make no difference. Perhaps it is down to my ISP being particularly busy at the moment?

I and others barely had any problems like this in the future. In fact one reason for me to choose the “installation on first boot” vs “one complete but over time outdated image” was that first experiments were always successful and that was confirmed over time.

Please scan your sd card for fitness (random tutorial) and try one more time at another hour…

Hi all, I just came back from a trip and almost did not get into my flat because openhab decided to change their configuration while I were gone:)( Luckily i have a key hidden in case OH goes down…)

So I am using openhabian, but the new openhab.cloud does not show up in the paper UI, so I assume that openhabian used an offline distro as base, so how can I get new extensions to show up in Paper UI?