openHABian hassle-free openHAB Setup

Tags: #<Tag:0x00007f5c8ff808e8> #<Tag:0x00007f5c8ff80780> #<Tag:0x00007f5c8ff805f0>

(Branden Smale) #489

That would be great, as it seems I have a Github account, but for whatever reason can’t sign in. I’ve tried to reset my password, but it says the email is not recognized…even though when I went to sign up, it said my email was already in the system, as well as my username…wierd…

(Branden Smale) #490

maybe i broke github…site is down now…

Need Help with homegear and HM-MOD-RPI-PCB
(space4u) #491

Hi @ThomDietrich,

(mini)Howto install the eq3 “HM-MOD-RPI-PCB” module on Raspberry 2 with openHABian,
All steps was run after a clean OpenHABian installation…

01 | update the system
sudo apt-get update
sudi apt-get upgrade
sudo rpi-update

02 | edit file and add the line
sudo vim /boot/config.txt

03 | edit file and remove the following entrys
sudo vim /boot/cmdline.txt
console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1

04 | edit file and remove the following line
sudo vim /etc/inittab
T0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100

05 | disable getty service
sudo systemctl disable getty@.service

06 | reboot the system
sudo reboot

07 | check whether service is really no longer running, it is important that we do not receive any output
ps -A | grep getty
output: nothing

08 | check the ttyAMA0 rights
ls -l /dev/ttyAMA0
output: crw-rw---- 1 root dialout 204, 64 Jan 15 00:02 /dev/ttyAMA0

09 | run openhabian-config and execute entrys:
sudo openhabian-config
01 | Update
02 | Basic Setup
03 | Java 8
04 | openHAB 2
11 | Optional: Homegear
20 | Serial Port

  • uncheck [ ] 1 Disable serial console

10 | reboot the system
sudo reboot

11 | edit file and remove the # symbole in the following lines
sudo vim /etc/homegear/families/homematicbidcos.conf

[HomeMatic Wireless Module for Raspberry Pi]
deviceType = hm-mod-rpi-pcb
device = /dev/ttyAMA0
responseDelay = 95
gpio1 = 18

12 | restart homegear service
sudo /etc/init.d/homegear restart

13 | now you can pair homematic devices with homegear
14 |now you can install the homematic binding in openHAB

( ) #492

Hey @space4u great you got it working. You could have saved yourself a few steps:

  • 01: openHABian starts by installing everything fresh, no upgrade needed.
  • 02: 08 are done for you by sudo openhabian-config --> Serial Port --> checking number 1
  • 09: 1-4 are not needed, that’s already done when you are first booting openHABian. I know that this is not stated anywhere and will fix that soon.

(Michael Aschenborn) #493

My Update did work. Thank you for your help.

Grafana sounds interesting - never heard about. What’s a good startingpoint?

And what is the nginx-Setting in your config-tool for?

( ) #494

Great :thumbsup:
I’ve written an exhaustive tutorial on Grafana: InfluxDB+Grafana persistence and graphing
Just select the nginx setting and you’ll see an extended description. Basically it will give you HTTPS and username:password authentication.

(Michael) #495

I also can’t get the built-in wi-fi to work on a Raspberry 3 that arrived today using the latest openHABian image. Using the recommended setup procedure from the Raspberry Pi website, when I try the command:

sudo iwlist wlan0 scan

I get an ‘iwlist’ command not found error

Also the wpa_supplicant.conf file (used to store the SSID and password) is not present.

Using a different sd card, installing the OS through NOOBS and enabling wi-fi through the desktop, the above command does what it should do (gives a list of available networks) and the wpa_supplicant.conf file contains the wifi details.

I’m using this RPi3 as a spare so if you want me to try out anything, let me know.

( ) #496

Did you install iwlist then? Maybe it’s as easy as that :slight_smile:

(Michael Aschenborn) #497

I was looking for a way to use user:pass - so thats great.
But I need it for the local network - and while it work now on port 80 with authentication, port 8080 is still available.
Is it possible to block the 8080-port?


(Michael) #498

You can’t install iwlist on its own but after a bit of searching I tried the following:

sudo apt-get install wireless-tools
sudo apt-get install wpasupplicant

Both installed but I now get a ‘wlan0 Interface doesn’t support scanning message’ when i use iwlist.

Also added this to etc/network/interfaces as suggested elsewhere:

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-ssid "*****"
wpa-psk "*****"

Again, no joy.

(Branden Smale) #499

i just did an openhabian update, also openhab update, basic set up, as well as an apt-get update /upgrade. rebooted the pi. openhab is not running, get a connection refused message, any ideas?

(paglia) #500

Hi - i’m running openhabian since October. Now i’m planning to migrate my entire installation from sd to an external disk.
Is there a suggested procedure or i can use a generic tutorial like this one: ?

( ) #501

That’s a special usecase I didn’t see yet. Should be covered by the following solution, could you try please

Add the following line to /etc/default/openhab2:


( ) #502

In the openHABian menu, there is an option for that. Only boot will stay on the sd card.
Another solution seems to be Berryboot. Check the comments above.

@Branden_Smale did you try sudo systemctl restart openhab2.service? Please check sudo systemctl status openhab2.service and /var/log/daemon.log as well as /var/log/openhab.log for suspicious lines.

(SiHui) #503

… or, if using a RPi3, boot directly from a SSD USB Disk without the need of a sd card at all … but it’s still in Beta (but works flawlessly).

(Michael Aschenborn) #504

nope. Even after restarting OH I can access :8080 without password.

(Craig) #505

After days of searching I found a hint which said to use the command:

sudo service networking reload

So I ran this and voila, I could disconnect the ethernet cable and both SSH and OpenHab were alive over WiFi!

My ecstasy was short-lived however since when I rebooted the Pi it could no longer connect at all :frowning: Not even with ethernet connected. Up until now at least the ethernet connectivity has been rock solid, so while I made a small breakthrough in the wireless issue, it doesn’t help if a can’t reboot my Pi and take it away from the router.

I wonder what caused the reload service to wipe out all connectivity. I had to run a fresh OpenHabian installation which works perfectly well.

I’ll continue to hack away at it, but if anyone has any insight as to what could be wrong it would be greatly appreciated

( ) #506

Oh that’s quite unfortunate! It would be great if we could solve that issue. I’m afraid I will not have the time to fix this problem myself in the next couple of days. Maybe somebody else could look into that?

In conclusion, which steps were needed in addition to the openHABian menu entry to get this far?

(Craig) #507

Nothing else so it was a bog-standard installation. I just entered the WiFi credentials via the Openhabian menu.

Tonight I have a fresh installation waiting, so I’ll attempt to recreate the issue and note anything interesting.

My mini-breakthrough does suggest that it’s possible under the WiFi setup where I’m staying (it’s a guesthouse so I don’t have access to any router settings, and being a guesthouse is the main reason why I want to move the Pi to my room and connect on WiFi!)

(Michael) #508

Openhabian menu? Didn’t know there was one.

Not everyone will go through 500 posts to find this so can I please suggest that the opening post of this thread and the main github entry is updated to include this.