openHABian hassle-free openHAB Setup

A USB stick will crash too? Should I use a external harddrive or SSD?

And will the hassle-free Pine64 image be available soon?

Pine64 is in progress but will take a few more days. Manual: Didn’t get you there. If you have an old openHAB 2 setup following the manual setup routine, best remove and start anew.

I’m reasonably new to OH and very new to Linux and the Pi.

What does binding the karaf console to all interfaces mean?
What do I get and what do I loose by choosing this menu optio ?

I’m trying to move my OH from OH1 on WinXP to a OH2 on a Pi3. What do I need to do for my Aeon3 USB stick. Is this something to do with the serial interface option in the menu?


great work, thanks a lot.
I am just setting up my Pi by a clean install with openhabian but I cannot get VNC to work - neither by activating it via raspi-config -> interfaces nor by installing vncserver via apt-get and running it.
I had an error msg saying that files were not found so I installed the X environment via
sudo apt-get install xserver-xorg-core xserver-xorg-input-all
xserver-xorg-video-fbdev libx11-6 x11-common
x11-utils x11-xkb-utils x11-xserver-utils xterm lightdm openbox
as a user suggested for jessie lite. Now I dont get the error msg anymore but vnc still doesnt work.

How to get VNC working? Would it be possible to include VNC as optional package in the openhabian-config menu?
Thanks again for your great work on OpenHABian!

Does this mean it’s not possible to update / upgrade like I use to do for the beta snapshots?
I tried sudo apt-get update and got:

Failed to fetch HttpError404

@NCO: They changed the repository location from cloudbees to bintray some weeks ago, see here:

So you have to follow these steps to adapt your settings. Or use openhabian with the options 1 and 2 (Update and Basic Setup) to do this for you.

@ThomDietrich: I changed from snapshot #743 to 2.0 stable using Openhabian. Worked without problems. Thanks again for your tool!

However, what happens if I want to stay up-to-date with the latest zwave binding changes? Chris regularly updates his binding. Do I get this updates when I do an apt-get update/upgrade? Or are these ongoing changes in the binding only visible in the snapshot version of the binding? And if so, can I choose only the snapshot version of the binding and for all the rest I continue using the stable release?

Thanks @jaydee73

just to make sure:
For the new official release I just need to adjust the list / location of OH2 (on openhabian) by:
echo 'deb stable main' | sudo tee /etc/apt/sources.list.d/openhab2.list

and then just run the usual
sudo apt-get update
sudo apt-get upgrade

Does this mean my config / things will be kept?

When you are using the snapshot version at the moment (offline or online version) and switch to the stable release version, you need to install the stable release version instead of doing an upgrade (otherwise the apt-upgrade would simply upgrade the installed snapshot version):

wget -qO - '' | sudo apt-key add -
echo 'deb stable main' | sudo tee /etc/apt/sources.list.d/openhab2.list
sudo apt-get update
sudo apt-get install openhab2

If you want to stay on the snapshot releases and simply want to change the repository and update to the latest snapshot release:

wget -qO - '' | sudo apt-key add -
echo 'deb unstable main' | sudo tee /etc/apt/sources.list.d/openhab2.list
sudo apt-get update
sudo apt-get install openhab2

The install openhab2 is necessary since there aren’t offline or online versions anymore.

And yes, config/things will be kept. I’ve only heard of habpanel settings who got lost… But as with any update: Backup first! :slight_smile:

Guys what are you doing? :smiley: Just use the search function or scroll up a few pages. You can also just check the Updates section in the first posting.

openHABian includes the steps to switch from the online/offline version to the stable 2.0.0. Just follow the instructions as I gave them here:

Hi @jaydee73, Hi @ThomDietrich,

Thanks to both of you. I will proceed as suggested.
Actually I read through some posts here, but > 600 posts are simply too many.
Sorry for that, though :blush:

1 Like

looks good so far.
Although PaperUI is not showing up yet, I assume it takes another few minutes…

Working like a charm!
Thank you all for your efforts.
Even Alexa is almost running perfectly!
Thanks… Thanks… Thanks so much!!

1 Like

I have tried 3 nights in a row to get openhabian running. with all failing.
the only thing I have not tried is a new memory stick.
I have openhab running on rasbian on another pi.
thought i would test this verision out due to the small footprint and having an extra pi to experiment with.
Raspberry pi 2 model B Ver 1.1
downloaded the most recent img file (12-16-16). Put on a 2gb microusb
plugged in pi to network and powered up.
Let run over night when I could not find it on the network.
Tried again. let it run for over an hour. Had a Heartbeat on ACT light.
ran angry ip to look for it… nowhere in sight.
at one point i did plug in the hdmi to see verbose responses.
I did notice a few FAIL while installing.
after install there was a few failed to start. ( one including Failed to start login service) forgot the exact wordings of the others

(12-16-16) referring to
Put on a 2gb microusb, are you booting from that usb?

Sorry MicroSD

95% of the time an openHABian installation fails it is due to the used SD card (5% network connectivity).
In your case I believe 2GB is not big enough. The complete openHABian installation will take up around 2GB and there should be some slack.

Please pay attention to documentation:

After selecting the option you will see another dialog explaining that. See also:

@ThomDietrich: Do you know the answer for this? Thanks a lot!

Installing an X server and vnc is not intended on openHABian. You should look into Samba and SSH. It’s the better way to interact with a dedicated small linux server. Do not use your powerful PC as the gateway to a crappy minimal remote control access.

If you still want to use VNC, use the search function. Users have installed VNC it in the past.

Hey @jaydee73 I’ve read about this and believe it will be updated. However I’m not sure, please ask in the 2.0 announcement thread to be sure.