openHABian hassle-free openHAB Setup

Hey everyone!
openHABian is slowly coming to other platforms and we decided to switch from pi:raspberry or ubuntu:ubuntu to one openHABian wide username+password combination. It’s your time to vote :wink:

  • openhabian:openhabian
  • enthusiast:smarthome
  • smart:home

0 voters

The poll will be open for a few days.


I would suggest to add this possibility to the utility as it is existing in raspi-config.

Why not openhab and habopen?

1 Like

Hello, i installed openhab2 on raspberry for a second time. But on the new installation the config with openhabian-config faild. It looks like testmassages, i these:

~$ sudo openhabian-config
[sudo] password for pi:
[openHABian] Checking for root privileges… OK
[openHABian] Loading configuration file ‘/etc/openhabian.conf’… OK
Bye Bye! :slight_smile:

and no Configmenue

Someone has an idea ?

Hello @nitram_reniek, I’ve seen this error just a few days ago. I have no clue why you saw it but that must have been linked to your SSH client. Would you mind telling me which this was? Anyhow, the message after that should include a fix for this problem :wink:

@bluesunit and @jkohl for you it’s probably the same thing.

@rtvb Because openhab is the system user for the openHAB daemon.

@lukics I’ll look into it.

openHABian on new adventures

After making the Raspberry Pi a stable and versatile platform for openHAB, we went ahead with the aim of a hassle-free openHAB setup. openHABian v1.1 is the first release to officially support a wider range of Debian/Ubuntu based systems. With version 1.1 we now also provide a Pine A64 ready to run SD card image!

All you need to know about openHABian in general can now be found in the official documentation article, updated regularly:

Release Downloads:

Changes since v1.0

A list of all git commits can be found here. Here’s the heavy stuff:

  • Includes all previously announced changes for the openHAB 2.0 final release
  • The build tool chain for the RPi image was removed as a fixed part and will be temporarily created
  • A build process for the Pine A64 platform was added next to the RPi build. This brought A LOT of small changes and improvements to both images as well as to the general setup process, which I can not simply list :sweat_smile:
  • All openhabian-config menu options are now considering certain platform restrictions and additionally needed installation steps. Menu entried, which are hardware specific, are no accessible on other platforms
  • A configuration file for openHABian was added under /etc/openhabian.conf
  • The end users linux username is not hardcoded as before but can now differ between systems and will be stored in the config file. For the RPi and Pine64 images this will be done automatically, a manually installed system will prompt for a username on first execution of openhabian-config
  • The way timezone and locale are set should now comply with the normal way of changing these. An option to change them inside the openHABian configuration tool will come soon, check the docs article till then
  • Oracle Java was replaced by the Zulu Embedded Java runtime (which is in general the better choice for openHAB and by the way made the openHABian installation on the RPi a whole lot easier and also a bit faster)
  • The Zulu installation includes the Charts widget bug fix
  • The login screen FireMotD received a few tweaks to support the Pine A64
  • Many small improvements and fixes

Some Stats: The openHABianPi image version 1.0 released 2016-12-16 was downloaded 10,306 times. The openHABian config tool is in average installed or updated 160 times per day.

Poll Results

The default username and password combination for SSH and Samba has changed to openhabian:openhabian. A big shoutout to everyone taking part in the poll above, also the ones voting for “smart:home”. Honestly also my personal favorite but the majority has spoken :mega: We should do this more often!


If you are already running openHABian on your system, just select the “Update” menu entry behind sudo openhabian-config, then execute “Upgrade System” and “Basic Setup” - That should be all.

You do not need to switch over to Zulu, if you are currently using Oracle Java. If you want to switch, please remove Oracle Java before doing so. You will have to do so manually:

sudo apt purge oracle-java8-installer oracle-java8-jdk
sudo apt-get autoremove
sudo rm -f /etc/apt/sources.list.d/webupd8team-java.list

Fresh Setup

Setting up your openHABian system should be as hassle-free as always. Please visit the documentation to find all you need to know:

Enjoy and Happy Hacking!!


Thanks for this great work and this awesome tool!!!

But I have problems with the downladed file.
I downloaded openhabianpi-ua-netinst-2017021801-git088eb4e.img and tried to write to sd-card.

But my sd-card is empty.

I repeated download and copy several times without success.
Then I tried a older image openhabian-ua-netinst-20161216-git52cc420.img and this works.

@ThomDietrich Is the file ok?


Great work, thanks.

A question for migrating to Zulu: I had to install the JCE 8 on my RPi installation, because the KM200 binding needs unlimited encryption. Is it good for me to move to Zulu?

Hello ThomDietrich,
i use putty to connect the Raspi, i have two of them. The older one has no problem, the new i installed yesterday, has the the problem. I used the openhabian image :openhabian-ua-netinst-20161216-git52cc420.img, i saw now there is a new one, can i use update, or should i better reinstall with the new Image ? At this point its no problem.

I like this projekt ! Its very usefull for my new hobby :wink:

Best reinstall :wink:

@lukics I don’t know about unlimited encryption but the choice is really up to you! Zulu is not better, it’s just another java runtime. Stay with JCE.

@anfaenger I sure hope so. Could you just do a fresh download?

Hello I tryed the new imge too, and i have the same problem, disk can’t read, no known filesystem.
The image seems to be corrupt. :frowning:

I did a fresh download and copy to the sd-card and got the same error again. And sd-card is empty.

When I download openhabian-ua-netinst-20161216-git52cc420.img and copy this file to the sd-card.
Everything is fine and I can see the content of the sd-card in my explorer.

I’m confused.

I’ve tested the image before uploading yesterday… Maybe there was a transfer error!? I’m not in my apartment right now but I’ll try to build a new image and upload in a few minutes…

@anfaenger @nitram_reniek please try again. I’ve uploaded a fresh build but am not able to test myself atm :confused: -> openhabianpi-ua-netinst-20170218-git11d8ebc.img

That did it! :slight_smile:
Now I could copy the image to my sd-card.

I just put the sd-card into my raspberry and installation started running.

Thank you very much.

1 Like

It seems that I have the same problem, so the same conclusion from me.


Fresh Image is fine!

1 Like

Any reason why apt-get update no longer pulls the latest nightly build? Pretty sure it worked only last week.

Have you updated to the latest openhabian version? There was a change of the repo last week. It’s not Bintray anymore. Maybe your apt-get still tries to get the build from bintray?

What need to be set to get nightly builds. Thought only release can be run.

Maybe I got a little bit confused because of the expression “nightly builds”.

Openhabian only uses the stable version at the moment. And the stable version is still hosted on Bintray. Only the unstable version (nightly build, snaphsot version, however it is called…) is now hosted elswere, see here:

You can’t switch from stable to snapshot within openhabian. I think ThomDietrich wants to add this in the future, but atm this isn’t possible.