openHABian hassle-free openHAB Setup

The steps will only recover the complete openHAB installation. I believe @hajen was aiming for the whole OS, with other software installed.
@hajen I’m sorry but I’m not quite sure how to migrate. You might need to reinstall, sorry for that. If you want, you can try the latest build from here but the v1.1 is just fine too.

@tjwesterby sorry I’m not sure what’s wrong with your setup. Please try again, maybe there was a server problem. You could also try the latest build from above.

@bob_dickenson finding the port of an accessory is easy by looking at dmesg while or after connecting the device.
@RHINESEL thanks for your help :wink:

@mortommy that doesn’t sound like any problem I can explain with the changes with v1.1… Did you make any progress?

@Zaphood1967 Many things are moving around openHAB. In general I’d say that’s a good thing. To stay up to date, you should subscribe to news in important categories and threads like the announcements category or the openHABian thread here.

@Mees.Mees I’m not sure. Most parts should work right away, I’d be interested in your findings. Please start with a fresh installation of the default orange pi image, then set up and execute openHABian the manual way.

@Klommer this shouldn’t have happened. If your everyday user is still called “pi”, please execute sudo smbpasswd -a pi and provide a password. You should be able to log in with these credentials afterwards.

@uwe_mutz I’ve not forgotten about you and actually implemented a few things that hopefully clarify a few things. I’ll contact you again later. Did you get the GUI installed? If you describe the steps you took, I can mention them in the documentation article. Would be a good addition for people wanting to work with a GUI.

yes @ThomDietrich,
In the file sshd_config the option AllowUsers was: pi, openhab
but the documentation says:

AllowUsers: This keyword can be followed by a list of group name patterns, separated by spaces.

I removed the comma and restarted the sshd service, now is working.

thank you.

Ah I see. But that’s not openHABian related. I’m not touching SSH and on my testing system there is no such line.

I cannot remember I changed the option value. Anyway thank you.

Exactly, think I know the way to do it in general on a RPi, but that involves usage of the rpi-update that is a no no at the moment as I understand it. Will pull myself together this weekend and reinstall it I guess an migrate openHAB and the other stuff running on it.


openHABian in international airspace

The v1.2 release changes and adds a few details in openHABian for a more intuitive experience for beginners and with new hardware, including devices connected by Wifi. The most important change with this release is the addition of a Raspbian Lite based image.

Changes since v1.1

All git commits can be found here.

Raspberry Pi Zero W

A few days back the Raspberry Pi Zero W (Pi0W) was released. The Pi0 is a cheaper and smaller Raspberry Pi with only a few external connectors and only one 1GHz core. The latter, especially the lack of a network port, made the Pi0 uninteresting as a “hassle-free” SBC for openHABian. The Pi0 W changes that because of it’s integrated Wifi/Blueooth module.

openHABian v1.2 brings full support for the Pi0W in unattended/headless mode. Read about Wifi setup below.

The Raspberry Pi Zero W is powerful enough to run openHAB and to control your small and mid-sized home / home automation system. It is also a great device as a slave system, e.g. only interacting with your heating system or the garage devices. If you can live with the limited count of connectors and the main uplink via Wifi, the cheap RPi0W might be a good choice for your openHAB(ian) installation.

Raspbian Lite base

If you payed close attention, you know that openHABian for the Raspberry Pi started as a project based on raspbian-ua-netinst, a minimal unattended network installer, perfect for what openHABian was aiming for. You will however also remember, that this rather special system had some restrictions and quirks. A “hassle-free” system should be as predictable as possible, however the differences to a standard Raspbian system confused some openHABian users. Another problem was the need for the support of a Wifi connection with the Pi0W.

With openHABian v1.2 we are introducing a Raspbian Lite based image in parallel to the raspbian-ua-netinst based image. The Raspbian image will take longer to flash but will overall be quicker to configure the system and start openHAB. Additionally it allows for a setup purely via Wifi and therefore is the only option for the RPi0W. As it is based on Raspbian as we know it, I expect this system to create less problems with GPIO or other issues known from the old base. The raspbian-ua-netinst based image is still fully supported and if you were happy with it so far, don’t hesitate to stick with it.

Wifi Setup

If you own a RPi3, RPi0W or a Pine A64, you can setup and use openHABian v1.2 purely via Wifi. You’ll need to make your SSID and password known to the system before the first boot in just a few steps:

  • Flash the system image to your micro SD card
  • Access the first partition from your file explorer
  • You’ll find the file openhabian.conf, open it in a text editor
  • Uncomment and fill in wifi_ssid= and wifi_psk=
  • Save, Unmount, Insert, Boot, Enjoy.

More clarity

The openHABian setup was always quite reliable. Still there were exceptions of cause. In these cases the current state of the installation and a possible error and its solution were not always easy to identify for a new user (at least not without further knowledge of the system).
With v1.2 we’ve added a tiny but useful little addition. The configuration and setup process takes between 5 and 60 minutes (based on device, connection type and bandwidth). During that time you can log in via ssh and will be presented with the configuration progress log, washing away all unclarity.


openHABian promotes a hassle-free system you can use instantly without further modification. There were however three topics not yet covered by openHABian as good as expected by some users: Hostname, Locale and Timezone.

Version 1.2 finally brings openhabian-config menu entries to change the system’s hostname, to adjust the timezone and to change the system language, if en_US.UTF-8 is not what you are satisfied with. Besides these menu entries the local time zone will now automatically be detected based on your IP, making a manual change mostly obsolete. With these additions raspi-config is now finally abandoned from the Raspberry Pi openHABian system.

This change and the one before was inspired by @uwe_mutz

Next Steps

As always: If you are on a previous openHABian release, you just have to execute sudo openhabian-config followed by the “Update” menu entry to gain access to all the latest changes. Please report all problems you encounter.

New users and Raspbian Lite image switchers:
Follow the instructions under
Choose the right image, use Etcher to flash the compressed image files (.img.xz)!


hi Community,
I was trying out the new raspbian-lite based installer:
burned with etcher on SD and put into my new raspberry 3.
Not using the wifi but connected via Ethernet it boots, does stuff for less(!!) than one minute and then shows the ogin prompt.
Nothing about openhab at all on the screen. The green LED has stopped flashing, I can Login using pi/raspberry.
I can ping the ip of the raspberry but not ssh into it, connection refused.
sudo openhabian-config gives : command not found.
what am I doing wrong…is the wifi configuration mandatory?

Well then something went horribly wrong, login and password are “openhabian”. Please remember to give the setup a few minutes to get ready. Please have a look here:

thanks for your reply!
pi/raspberry should not be possible I agree, that’s why I mentioned it.
I should have mentioned that I have a screen connected and logged in via the connected keyboard.
I thought I could follow the Installation progress on the screen…Should I wait until I can login via ssh ?
I’m flashing again and will try that.
update: tried again, same result.
when finished could not connect via ssh, logged in via terminal, checked /var/log, could not find any logs related to openhab Setup
I’m now trying the ua-netinst package …
thanks a lot,

I made exactly the same experience as Andy.
After power on the directly attached monitor showed that the openhabianpi-raspbian Setup was finished in about 30 seconds on my Raspberry Pi 3 (the openhabianpi-ua-netinst image installed before took about 25 minutes to install!)
Then no logon with user “openhabian” was possible, only logon as user “pi”. Nothing at all from openhab was to find anywhere…

@andy95 @Hansohm thanks for reporting this. I’ve generated and tested dozens of images over the last couple of days. After everything was finished I generated a final set of images which seems to suffer from a generation issue I didn’t catch. I’ve uploaded a new image.

Good luck :wink:

thanks for the quick update, the new download is currenty installing.
I can now see the /boot/ being executed and the other openhab stuff getting installed!
have a nice weekend!

Thanks for your great work.
With the new image I got everything installed this morning and in the meanwhile my old sitemaps work as they should.

(Entering a different hostname in the Boot Section File “openhabian.conf” didn´t work, but that wasn´t a real problem since it is easy settable with “openhabian-config” later)

1 Like

Hi guys!
after almost 2 hours without any SSH access (connection refused) to my PI during setup I gave up and rebooted my PI… I found that webpage and SSH are working now and I was able to configure Openhab.

but when I log with SSH I get this error:

Attention! The openHABian setup process is not finished yet.

Is there any way to complete the setup? do I need to re-do everything? It took a lot of time, more than 45 minutes indicated on the website… I don’t know what is wrong.

thanks for your help

PS: what is the difference between this two? I used the .img file

I did not use openhabian yet, but it looks like the


is a minimal image, which will retrieve almost all through your internet connection to complete the system installation (netinstall), while


is (maybe) a more complete image, but this one is packed with XZ-Utils (you could use 7-zip to extract the image).

I don’t know how long the installation process will last with netinst image, but the Raspberry will download about 1.5GByte (just a guess) through installation.

I just upgraded one Raspberry Pi 2 from wheezy to jessie (through apt-get dist-upgrade), that lasted about 5 hours (downlaoding the raspian image was about 10 minutes, plus 10 minutes to extract to a microSD card).

1 Like

I thought so,
at the end I restarted everything starting with the .img.xz file and now openhab is running fine.

Having some issues with the samsung smart tv binding but this is another story.

Thanks for reporting! I’ve already implemented all needed steps but apparently forgot to include the function in the unattended setup :see_no_evil:

1 Like

Hello Lorenzo,

an installation shouldn’t fail. It didn’t ever happen to me during my countless testings. However it seems that some internet connections or package server mirrors are less reliable than others. These were the most common causes for this problem in the past.

Didn’t I explain this in the announcement? Basically it’s like @Udo_Hartmann said. They are different ways to install openHABian on your RPi (see announcement). The xz image is compressed and does not need to be extracted, just flash it with etcher (just as I said in the announcement). The installation takes 5-60 minutes based on your internet connection (where did I say that before? Ah yes, in the announcement) :relieved: :smile:

In case the decision is still not easy: Go with the Raspbian Image.

Cool! I wasn’t aware of that…

Indeed. Etcher will soon also contain another neat feature: