openHABian hassle-free openHAB Setup

In this case option 2 of the mentioned “Serial Port” menu will come in handy :wink:

Tried to upgrade and run basic setup about 40 minutes ago and got a bunch of 404 errors for cloudbees. Upgrade failed of course.

I’ve just executed

  • “Update”
  • “Basic Setup”
  • “OpenHAB 2”

No problem.
However, that’s no wonder, as cloudbees isn’t present on my system anymore. Why is it on yours!?
Check the output of the following command for “cloudbees” please:

cat /etc/apt/source.list.d/*

I get “No such file or directory”.

Just to confirm, when updating should I do “OpenHAB 2” or upgrade via apt-get?

This is what I get when running “Basic Setup”:

W: Failed to fetch HttpError404

W: Failed to fetch HttpError404

E: Some index files failed to download. They have been ignored, or old ones used instead.

Derp… Failure of reading instructions. That’s what I get for waiting a few days and relying on memory. DISREGARD!

So you got it working? pheww I’m relieved.

@ThomDietrich I’m still using an old version of openhabian from ~2 months ago.
The last times, I used the apt update/upgrade process, the installation went fine - but some bindings were disabled or things were missing.

While in OH1 it was easy to backup all items/sitemaps/rules - in OH2 there are a lot of different places, where individual data seems to be stored. Things, Items added by UI vs. Items added by file, and so on…

I would like to upgrade, but have to ensure, that my persistence DBs and settings will stay.

My steps would be:

  1. create a backup of the full sd-card with Win32DiskImager
  2. sudo openhabian-config -> Update -> OpenHAB2
  3. then sudo apt update
  4. then sudo apt upgrade
  5. then restart

Would you think that Items, Things, Persistems will survive this?


Hi @madeinnorte,

Did you manage to connect to your Pi on WiFi?

I ran the script on ethernet and everything went fine, except for WiFi. After installation I entered the WiFi credentials and disconnected the network cable but I could not connect to it on WiFi.

I’ll try again tonight and post any errors / logs in case that may help give us some clues.


there are some changes refering snapshot repository (please see link)

I plan to setup a new system. Do I have to do all these changes described above or did you already fit your image to the new reqs. If not, do plan to include the changes in the near future?

Many thx in advance

kind regards


You could have just scrolled upwards a few pages… openHABian hassle-free openHAB Setup

So many things changed over the last few months, I really can’t tell you for sure. Do your backup, once via Win32DiskImager, secondly create a simple file copy of these folders (to be able to access them easier):

  • /etc/openhab2
  • /var/lib/openhab2
  • /usr/share/openhab2

Then execute sudo openhabian-config -> Update -> Basic Setup -> OpenHAB2

That should be it. You will then already be on the latest build, so no need for an apt upgrade. Restarting is not needed but will not hurt :wink: You might see the error @RHINESEL reported while Basic Setup, that’s no real error at this point.

Afterwards stop the openhab2 service and restore your files from the copies from before. If you are careful you should be able to restore the most. If your current setup is still using the mapdb, you will not be able to convert it to jsondb. In this case a a bit of work will be needed. Persistence might not be as big of a problem, you should btw consider switching over to Grafana :wink:

Good luck!

1 Like


Still no connection on to WiFi after re-running the installation.

PuTTY, Samba and the runtime are all fine.

I’ve made sure that the SSID and passwords entered are correct, so really not sure why I can’t connect to the Pi on WiFi.

Here’s the Karaf output with an error returned at the end:
$ ifup wlan0
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.

All the output:

[openHABian] Setting up RPi 3 Wifi...
$ apt -y install firmware-brcm80211 wpasupplicant wireless-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libiw30 libnl-3-200 libnl-genl-3-200 libpcsclite1
Suggested packages:
  pcscd wpagui libengine-pkcs11-openssl
The following NEW packages will be installed:
  firmware-brcm80211 libiw30 libnl-3-200 libnl-genl-3-200 libpcsclite1
  wireless-tools wpasupplicant
0 upgraded, 7 newly installed, 0 to remove and 3 not upgraded.
Need to get 2,746 kB of archives.
After this operation, 7,040 kB of additional disk space will be used.
Get:1 jessie/main firmware-brcm80211 all 0.43+rpi5 [1,678 kB]
Get:2 jessie/main libnl-3-200 armhf 3.2.24-2 [50.5 kB]
Get:3 jessie/main libnl-genl-3-200 armhf 3.2.24-2 [18.3 kB]
Get:4 jessie/main libpcsclite1 armhf 1.8.13-1+deb8u1 [53.7 kB]
Get:5 jessie/main libiw30 armhf 30~pre9-8 [34.8 kB]
Get:6 jessie/main wpasupplicant armhf 2.3-1+deb8u4 [778 kB]
Get:7 jessie/main wireless-tools armhf 30~pre9-8 [133 kB]
Fetched 2,746 kB in 1s (2,643 kB/s)
[master aa15684] saving uncommitted changes in /etc prior to apt run
 Author: pi <pi@openHABianPi>
 2 files changed, 62 insertions(+), 62 deletions(-)
Selecting previously unselected package libnl-3-200:armhf.
(Reading database ... 26087 files and directories currently installed.)
Preparing to unpack .../libnl-3-200_3.2.24-2_armhf.deb ...
Unpacking libnl-3-200:armhf (3.2.24-2) ...
Selecting previously unselected package libnl-genl-3-200:armhf.
Preparing to unpack .../libnl-genl-3-200_3.2.24-2_armhf.deb ...
Unpacking libnl-genl-3-200:armhf (3.2.24-2) ...
Selecting previously unselected package libpcsclite1:armhf.
Preparing to unpack .../libpcsclite1_1.8.13-1+deb8u1_armhf.deb ...
Unpacking libpcsclite1:armhf (1.8.13-1+deb8u1) ...
Selecting previously unselected package libiw30:armhf.
Preparing to unpack .../libiw30_30~pre9-8_armhf.deb ...
Unpacking libiw30:armhf (30~pre9-8) ...
Selecting previously unselected package firmware-brcm80211.
Preparing to unpack .../firmware-brcm80211_0.43+rpi5_all.deb ...
Unpacking firmware-brcm80211 (0.43+rpi5) ...
Selecting previously unselected package wpasupplicant.
Preparing to unpack .../wpasupplicant_2.3-1+deb8u4_armhf.deb ...
Unpacking wpasupplicant (2.3-1+deb8u4) ...
Selecting previously unselected package wireless-tools.
Preparing to unpack .../wireless-tools_30~pre9-8_armhf.deb ...
Unpacking wireless-tools (30~pre9-8) ...
Processing triggers for dbus (1.8.20-0+deb8u1) ...
Processing triggers for man-db ( ...
Setting up libnl-3-200:armhf (3.2.24-2) ...
Setting up libnl-genl-3-200:armhf (3.2.24-2) ...
Setting up libpcsclite1:armhf (1.8.13-1+deb8u1) ...
Setting up libiw30:armhf (30~pre9-8) ...
Setting up firmware-brcm80211 (0.43+rpi5) ...
Setting up wpasupplicant (2.3-1+deb8u4) ...
Setting up wireless-tools (30~pre9-8) ...
Processing triggers for libc-bin (2.19-18+deb8u6) ...
Processing triggers for dbus (1.8.20-0+deb8u1) ...
[master 2f71fc6] committing changes in /etc after apt run
 Author: pi <pi@openHABianPi>
 14 files changed, 1594 insertions(+), 1 deletion(-)#######################.]
 create mode 100644 dbus-1/system.d/wpa_supplicant.conf
 create mode 120000 ifplugd/action.d/action_wpa
 create mode 100644 libnl-3/classid
 create mode 100644 libnl-3/pktloc
 create mode 120000 network/if-down.d/wpasupplicant
 create mode 100755 network/if-post-down.d/wireless-tools
 create mode 120000 network/if-post-down.d/wpasupplicant
 create mode 100755 network/if-pre-up.d/wireless-tools
 create mode 120000 network/if-pre-up.d/wpasupplicant
 create mode 120000 network/if-up.d/wpasupplicant
 create mode 100755 wpa_supplicant/
 create mode 100755 wpa_supplicant/
 create mode 100755 wpa_supplicant/
Updating FireMotD available updates count ...

$ ifdown wlan0
ifdown: interface wlan0 not configured

$ ifup wlan0
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.
OK (Reboot needed)

We hope you got what you came for! See you again soon ;)
[19:36:53] pi@openHABianPi:~$

Did you get yours working?

Any ideas?

Hey @ThomDietrich,
I have tried to uncheck the serial disable box in openhabian-config serial menu.
After the reboot I check the serial menu again.
But the setting wasn´t saved, the checkbox is still enable :frowning:

am i able to access the addons folder via samba? i have looked through them under user directory and found no openhab2 folder.

Thank you, it worked. I have now access to openhab2 => great :slight_smile:

Now I try to put a binding in the path o f/usr/share/openhab2/addons via FileZilla with user pi but I don’t have access to this folder. What can I do?

@Branden_Smale @DeepSpaceSeven The addons folder is already shared via Samba. The corresponding share should be named “openHAB-sys”. You might still have the problem that you do not have write access to it. In this case it would be safe to run sudo chmod g+w /usr/share/openhab2/addons on the remote SSH console (untested).

Ah, almost forgot to mention that: Why are you looking for the addons folder? If you are not testing a brand new binding or were asked to try a development build, chances are high you do not want to add add-ons this way. If possible use PaperUI to install bindings.

@space4u I see how I tricked you there :smile: The settings will be modified per your selection (except for resetting option 1) but the ticks selection you are seeing is always a (random) default selection. This could be changed to represent your systems state. Do you think that would be something? Do you want to look into that? Here are the corresponding code lines.

Hey @UglyKidJoe I am not using wifi myself. Maybe somebody else has more insight. @Vincent would be a good candidate to mention here :wink:
In the meantime you could try to find the problem your self. Check this article and search for “Raspberry Pi 3 Raspbian Wifi” on google.

Let us know if you find a solution and what was wrong with the setup!

i want to use the dmx binding, not included in paperui yet. ill check it out this eve, thx.

what would be awesome is an option to do this on upgrade through config menu…meaning when you upgrade openhab2, gives an option to backup, that way it would be hard to miss this step, creating huge problems after upgrade.

Still waiting for the issue ticket :wink: