openHABian install problems

Still having problems with installation…
I think the repository isn’t signed correctly. When running apt-get update it always tells me, that the repo for openhab isn’t signed. Editing the /etc/apt/sources.list.d/openhab.list file allowed me to ignore this warning (setting truested=true option), but I still can’t get the setup script to work. Still failing with the PGP Error.

I almost got everything to work. Running the scripts one-by-one in a root shell (running the scripts with sudo didn’t work!) worked for me. Now the first-boot.bash script runs to the 3rd-last line without failures, but in the 3rd-last line it cannot find the /boot/webif.bash file:
if hash python 2>/dev/null; then bash /boot/webif.bash inst_done; fi
Where does this file come from/when should it be copied to the /boot/ or when should it be generated to /boot/?

of course, because fetching the repo key failed

That it should no longer do, the script should continue now. Remember to update openhabian-config on start.

don’t bother, it’s only used to display install status

I copied the file from /opt/openhabian/build-images/ to /boot/ and after that the startup script succeeded. So everything works now :slight_smile: