openHABian logs

I updated my openhabian to 3.0
When I open up http://192.168.1.30:9001/, it should display the log…
It does open a page but it shows the old logs from openhab2.
The title reads “tail -f /var/log/openhab2/openhab.log /var/log/openhab2/events.log”
I remotely remember some http server config needs changing to point to the new root folder “openhab”. Can you give me a hint, please ?

Other than that so far things run smoothly, just some getMonthOfYear hickups…

You did not upgrade openHABian to 3.0, as latest is 1.6.2.
You tried to upgrade openHAB to 3.0, bit did not read the provided information.
With openHAB 3.0, folder structure changed to openhab, no openhab2 any more.
Therefore the init for frontail needs to be adopted.

2 Likes

@hmerk: that was not helpful. If you don’t know it- just leave it alone.

Anyone else having a problem with the LogViewer (frontail) displaying the old logs from OpenHAB2 after upgrading to OH3:

You would have to change the path in /etc/systemd/system/frontail.service. In this file you replace two occurrences of “openhab2” with just “openhab”. Save, exit the editor.
Now, as root, do
systemctl daemon-reload
systemctl restart frontail.service

Refresh your browser window and you should be good to go.

3 Likes

I have also provided a fix for openhabian to get this running again from installation directly.

Edit:

My pull request got rejected.
Turns out that you have to choose the openHAB 3 branch in openhabian config instead of stable which i assumed to be the latest openHAB3 release.

1 Like

I have updated my OH2,5 to OH3,0 now. After the Update my http://openhab:9001/ has also stopped updating…
-> I use Openhabian on my Rasberry.

openhabian-config -> there is an option to install FRONTAIL

Events log has been changed so its not logging by default. I use the event bus in the dev tools on the main UI

edit: This is incorrect it is a bug that was fixed but still persists for me in release.

  • openHABian v1.6.1-1059(010ded5)
  • vanilla installation
  • selected “openHAB3” in 01 branch
  • tried 21 Log Viewer in openhabian-config to install Log Viewer
  • got this error:
│ There was an error or interruption during the execution of:                  │
│   "20 | Optional Components"                                                 │
│                                                                              │
│ Please try again. If the error persists, please read                         │
│ /opt/openhabian/docs/openhabian-DEBUG.md or                                  │
│ https://github.com/openhab/openhabian/blob/master/docs/openhabian-DEBUG.md   │
│ how to proceed.  

something I can do on this?

happened to me too. It took quite long and after that OH did not start at all. Turned out Java JDK was damaged.

what does that mean? Your starting point is unclear.
HW? OS ? Pls quote the instructions you followed.

So you changed the environment to work with OH3.
And how did you install OH3 itself ?

What about doing what the tool tells you for a start ?
Without a debug level log noone can do anything about it, and that log only you can provide.

Frontail and its installation are totally unrelated to Java so that’s a misleading comment.

exactyl the same for me , no fix found so far.

it would be higly appreciated, if you can guide me/us to do so and that we can provide such info for you. i am / we are not professionals like you are. it’s not that we didn’t read anything, its just our missing understanding in those things. thanks

it’s not fully misleading. because this happend to me too. i tried to install the Frontail via openhabian-config and after that my Java reverted back to Java 8 and after OH restart it failed. and it took me also a while to find out, that i need to install Java 11 via openhabian-config again.

It would be highly appreciated if you properly read the docs and my response before and rather than claiming you did.
This is a quotation of the tool output from 3 posts up:

│ Please try again. If the error persists, please read                         │
│ /opt/openhabian/docs/openhabian-DEBUG.md or                                  │
│ https://github.com/openhab/openhabian/blob/master/docs/openhabian-DEBUG.md   │
│ how to proceed.  

You didn’t do what you were asked to else you would know how to generate the debug log I asked for
because it described in the debug guide document this message clearly pointed you at.

Frankly I’m not willing to help people that expect me to but do not show this minimum required effort on their own part themselves.

No. Those two are unrelated so it is misleading to indicate that as a possible cause. Will just result in more people looking after things and arbitrarily try stuff that isn’t related to the problem they want to solve.

the guide tells me:

edit the config file `/etc/openhabian.conf` using the editor of your choice (use `nano` if you have no idea) and change the `debugmode` parameter to either `on` or `maximum` right away (default is `off` ).

and my config file looks like this

# Modify your openHABian settings
# Handle with care, only touch if you need to!!

hostname=openhab
username=openhabian
#userpw=xxxxxxxx

# Language and time. Be sure to set these to valid values
timeserver=0.pool.ntp.org
locales="en_US.UTF-8 de_DE.UTF-8"
system_default_locale="en_US.UTF-8"
#timezone=Europe/Berlin

# Wi-Fi settings. An ethernet connection is recommended
# Requirement: RPi3, RPi0W, PineA64 or a supported external Wi-Fi dongle
# Fill in your SSID and password below, leave empty to use ethernet
wifi_ssid=""
wifi_psk=""

# Wi-Fi setting. Select a two-letter country code suitable for your location
# E.g. US (default), DE, AU, NZ...
# You may infringe on local legislature otherwise
# See https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 or /usr/share/zoneinfo/zone.tab
wifi_country=""

# vim: filetype=sh


there is no “debug parameter” which i could change to “maximum” or “on”

is it just “debug=maximum” ? i don’t want to do things wrong, and thats the reason i am asking for help.

And to even cross-post into someone else’s thread, be it related or not.

I wish you a Merry Christmas, all of you.

That was actually a bug that was fixed prior to release. It should still log to events.log by default.

1 Like

I thought it was clear… downloaded openHABian and configured it to load oh3 and zulu11 on the SDCard
after first start, sshd into openHABian upgraded itself to 1.6.1-1059(010ded5), then tried to 21 Log Viewer and ran into that error.

But: Today openhabian-config updated itself to 1.6.1-1060(688ec36) and now it works! Thank you!

No that’s why I asked. And it’s still unclear. Did you use the image ?
Cloned openHABian repo on top of something “vanilla” (what OS in fact?)
There’s multiple ways to install openHABian.

yes, that’s what I did, taken the current 1.6 openhabian image.