OpenHABian Milestone upgrade fails

Hello,

This could be due to my use of VM installation, but selecting openhabian-config menu’s switch version to Milestone fails.

I have Rasberry Pi3B version as well, and that one worked fine. So I set debug=maximum and compared line by line. It looks like the issue is “adding required keys to apt” line where the link seems to be incorrect.

Below is VM version (not working)

+ add_keys 'https://bintray.com/user/downloadSubjectPublicKey?username=openhab'

In contrast, the working Rasberry Pi version has

+ add_keys https://openhab.jfrog.io/artifactory/api/gpg/key/public

So it looks VM version is looking at long site for key fetching. How could I fix this?

P.S. I tried couple different VM instances, and both have the same issue.

UPDATE: SOLVED

In summary, my issue apparently was due to the fact bintray site retired. However, there was a confusion (myself). Apparently, openhabian configuration tool and openHAB are separate/independent on their versions. To get the latest experience of openhabian, I needed to change openhabian configuration tool version to “MAIN”. This fixed the issue of openhabian configuration tool. From this point, I could use the tool properly and change openHAB (core) version.

Specific steps I took are:

Step 1: openhabian-config
Step 2: 01 select branch
Step 3: Move down to Main branch and HIT space bar to ensure * moves there. Hit Enter
Step 4: Go to option 40 and select Milestone branch (this is the branch I wanted) and hit enter

Now its all working.

That seems to be different versions of openhabian-config.
Make sure to use the latest version of openhabian-config on the VM.
You can compare the versions in the header of the window.

It is for sure related to:

Properly explain your setup when asking for help.
What OS do you run in VM ? What’s the openHABian version of that, did you upgrade openHABian recently ?

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

Thank you to both for quick reply. It does make sense the issue related to the Sunset of Bintray.

I see my version of OpenHAB is 3.0.2. The openHABian version on the VM version as well as Rasberry Pi version both say 20210316-1251 for patchday.

Is there any command that allows only openhabian-config/openhabian version only upgrade?

Thank you

You still didn’t say which OS you run. It’s annoying if you don’t provide that info with your question but even more so if you’re asked to provide it and don’t.

Sorry. You must have placed the comment while I was also writing mine, as I did not see yours. I apologize.

Here are the details.

VM OS - Debian 10.9.0
OpenHABian version I surmise 20210316-1251?
Recent upgrade - Yes, I have tried to apply “Apply Improvements, Upgrade System, Install openHAB” all before trying switch the installed version.

No. But when you start openhabian-config it’ll offer to update itself if there’s anything new. Seems you didn’t do that in your VM.

Why do you think that? Is the patchday version 20210316-1251 not the latest? I think I saw the message with OpenHabian on Rasberry Pi so I think I know the screen, but my VM version won’t show that. Having said this, at the moment both Rasberry Pi version (the functioning one) and VM one both looked to have the same patchday.

I now got one of VM version working, but not sure if this is acceptable way of installing or am I actually duplicating some unnecessary components?

  1. Installed OpenHABian on VM running fresh clean Debian using method described: openHABian | openHAB

  2. Since I still encountered the same issue as mentioned, I used Download openHAB | openHAB Linux Milestone installation using APT installation steps.

I can see openhabian-config, version of openhab itself is indeed Milestone. However, I am afraid somehow openhabian and openHAB are not tied?

Again, I appreciate all your expertise and help here.

Yes and no. It does not increase the number on every patch.
Try again, there now should be a new version id displayed as of today, that includes the bintray patch.

I don’t know what you mean by that. They are independent of each other.

Thank you for the quick reply.

VM version does not seem to see any new update.

In the mean time, I tried to do the fresh install just now. Following the official instruction: openHABian | openHAB.

This is output I see.

2021-05-04_18:24:16_CEST [openHABian] Setting locale based on openhabian.conf... OK (reboot required)

2021-05-04_18:24:22_CEST [openHABian] Setting hostname of the base system based on openhabian.conf... OK

2021-05-04_18:24:22_CEST [openHABian] Installing basic can't-be-wrong packages (screen, vim, ...)... OK

2021-05-04_18:25:09_CEST [openHABian] Installing additional needed packages... OK

2021-05-04_18:25:55_CEST [openHABian] Adding slightly tuned bash configuration files to system... OK

2021-05-04_18:25:55_CEST [openHABian] Adding slightly tuned vim configuration file to system... OK

2021-05-04_18:25:55_CEST [openHABian] tailscale VPN installation... SKIPPED (no preauthkey defined)

2021-05-04_18:25:55_CEST [openHABian] Applying miscellaneous system settings... realpath: '': No such file or directory

FAILED (setcap java)

OK

2021-05-04_18:25:55_CEST [openHABian] Downloading FireMotD... OK

2021-05-04_18:25:56_CEST [openHABian] Installing FireMotD... OK

2021-05-04_18:25:56_CEST [openHABian] Generating FireMotD theme... OK

2021-05-04_18:25:58_CEST [openHABian] Setting up FireMotD apt updates count service... OK

2021-05-04_18:26:00_CEST [openHABian] Installing Java Zulu prerequisites (libc, libstdc++, zlib1g)... OK

2021-05-04_18:26:06_CEST [openHABian] Downloading Java Zulu 11 32-Bit OpenJDK... OK

2021-05-04_18:26:09_CEST [openHABian] Installing Java Zulu 11 32-Bit OpenJDK... OK

2021-05-04_18:26:09_CEST [openHABian] Installing Java Zulu CEK to enable unlimited cipher strength... OK

2021-05-04_18:26:09_CEST [openHABian] Beginning install of latest openHAB3 release (stable)... OK

2021-05-04_18:26:09_CEST [openHABian] Adding required keys to apt... FAILED

2021-05-04_18:26:10_CEST [openHABian] Adding openHAB syntax to vim editor... OK

2021-05-04_18:26:11_CEST [openHABian] Adding openHAB syntax to nano editor... OK

2021-05-04_18:26:12_CEST [openHABian] Adding openHAB scheme to multitail... OK

2021-05-04_18:26:12_CEST [openHABian] Preparing openHAB folder mounts under '/srv/openhab-*'... OK

2021-05-04_18:26:13_CEST [openHABian] Installing Samba... OK

2021-05-04_18:26:36_CEST [openHABian] Setting up Samba network shares... OK

2021-05-04_18:26:36_CEST [openHABian] Setting up Samba service... OK

2021-05-04_18:26:36_CEST [openHABian] Applying file permissions recommendations... FAILED (please execute after openHAB is installed)

So it looks like Adding required keys to apt… FAILED is failing already at this stage.

Thank you for the information. With above statement, I am now comfortably upgrading to 3.1.0M4 via manual upgrade through CLI rather than Openhabian-config tool. Not sure if it is the best way to test but when checking openhab version via command line, prior to upgrade said 3.0.2 and after upgrade it says 3.1.0 M4.

Thank you all for the help,

I have to assume openhabian just is not fully compatible to MY virtual machine setup.

openhabian uses apt for package management. I assume that your linux install also uses Debian .deb packages either via manual installation or via apt installation thus they will use the directories during installation.

Switch to main branch (you are on openHAB3 branch if you used the manual installation instructions)

No it should be. It’s probably just the branch thing. Even though you have it working now, try again upgrading inside openhabian-config.

Oops. I have somehow edited above post.

Anyways, thank you all!

Thanks for bearing with me. That actually did the trick. I thought I did change to MAIN branch after seeing your first suggestion but it turned out, I did not hit SPACE bar, instead I was hitting enter… Rookie mistake.

But that was indeed the trick. Thank you so much. I will mark the solution and update original post so if anyone else encounter similar problem, hopefully it will be helpful.

Truly thanks to all, and I am sure to ask more question in the future but now off to excitement of OpenHAB!