openHABian - Mosquitto MQTT failed to start

Tags: #<Tag:0x00007f4348780b80> #<Tag:0x00007f4348780ab8> #<Tag:0x00007f43487809f0>

Thanks Marcus for your prompt help. I suffered the same issue with a new install of the openhabian image on RPi3b.
Following your instructions, repeated below for those that need it too, everything works as it should, no errors:

"mkdir -p /var/log/mosquitto /opt/zram/log.bind/mosquitto
chown mosquitto /var/log/mosquitto /opt/zram/log.bind/mosquitto
systemctl start mosquitto.service

Create /lib/systemd/system/mosquitto.service.d/override.conf to contain

[Unit]
After=network-online.target zram-config.service
Wants=network-online.target zram-config.service
"
Thanks for your help.

Hello! Post 41 solved this issue for me after fresh openhabian install with latest 1.6 openhabian
Thank you!

I was having a similar issue. After installing Mosquitto using openhabian-config, everything seemed to work fine. But after doing some troubleshooting to get MQTT working, Mosquitto stopped working. I tried to find log files, run files, etc., but couldn’t find any indication there was a working version on the Pi (3B+). I tried reinstalling it a few times (as per the instructions) - no go. I tried removing it with apt and reinstalling with openhabian-config - same issue. Finally, I removed it and reinstalled it with apt - it is working again, well kind-of. Being my first iteration of MQTT, I’m having other issues, but at least the broker is online.

I got the same problem. Mosquitto worked well directly after install but after reboot it stopped working. I don’t know anything about Linux. The last three years I somewhat managed to use openhab using the config files. I was happy when openhabian came around and you didn’t have to be a linux-expert to use openhab. Coming around to version 2.5 on my raspberry 4, I tried upgrading my setup. Through much trial and error I managed to write some things files, which, due to the lack of documentation, is really difficult. When I wanted to restart and installed openhab using the openhabian installer, I encountered the same problem as others in this thread. I uninstalled the zram using the openhabian config, but this didn’t help. What should I do?

PS: Suggesting I check some xyz-config file isn’t helpful, because I don’t understand the linux system.

This problem is back on a fresh install of OH3.0 on RPI3. It is fixed by the steps in post #41

I don’t know how to report this to the devs that are debugging OH3. Can somebody do that for me or point the way?

But make sure you understand what you talk about to select the proper addressee.
Mosquitto isn’t part of OH3.

It is part of the openHABian Configuration Tool, and somehow it doesn’t install correctly, where it was working in previous versions.

Thanks for you answer I will file a bug!

Bug reports are only useful/can only be worked upon when they show the problem/misbehavior happen so provide a log showing this and do not forget to describe your starting point.
Set debugmode=maximum in openhabian.conf and record the required output.

Update openHABian (restart openhabian-config) and see if it works to reinstall mosquitto now before you do.

Hi, I just did a fresh install of OH3 (openhabian-pi-raspios32-v1.6.2.img.xz) and I have the same problem.
When it started it was working fine and I did add a user
After the first reboot Mosquitto was not longer running
I followed the steps suggested above and it restarts but my user is no longer valid

Thanks

hi markus,

this works alsow for me !
thankx a lot !

try post 41 from this topic

for everybody else, who has this reboot problem too!

Thanks, had the same problem with a fresh openhabian installation (1.6.2) - these instructions did the trick :slight_smile:

Just installed 3.0 from scratch and had the same problem. Also solved by these instructions.

Which openHAB install method / instruction did you follow?
Did/does /etc/systemd/system/mosquitto.service.d/override.conf exist ?

For me it worked with:

sudo nano /etc/systemd/system/mosquitto.service.d

Afterwards it created a overwrite.conf file.

For sure not as you cannot text-edit a directory

And please answer my questions.

I reposted your instructions. I only edited with the nano editor, because there was no overwrite.conf.

So far I can only tell that it worked and now I have this .conf file what you posted

Hi,
in my case I followed the instructions at post#41.
/etc/systemd/system/mosquitto.service.d/override.conf did not exist.

Thanks