Openhabian: Move to SSD fails

After my SD card wore out, I installed the last openHABian on a new one.
It worked fine - but moving the root to the SSD fails with the following error:

[openHABian] Preparing device '/dev/sda'... FAILED (partition)

openhabian@openhabian:~ $ sudo df
Filesystem     1K-blocks    Used Available Use% Mounted on
/dev/root       30388284 4957924  24154020  18% /
devtmpfs          465280       0    465280   0% /dev
tmpfs             498560       0    498560   0% /dev/shm
tmpfs             498560    1368    497192   1% /run
tmpfs               5120       0      5120   0% /run/lock
tmpfs             498560       0    498560   0% /sys/fs/cgroup
/dev/mmcblk0p1    258095   48703    209393  19% /boot
/dev/sda2       30388284 4854796  24257148  17% /storage/syncmount
tmpfs              99712       0     99712   0% /run/user/1000

What’s wrong?

Thanks, Boby

openHABian has ZRAM to protect against SD wearout so noone needs to move to SSD.
Move to USB is an oldish generic function from the early days of openHABian and provided just as-is.
It is discouraged to use and not supported.
If you still want to move you can set debugmode=maximum to find out what’s failing.
But I’m afraid you’re on your own there.

Its a bit unclear wether he used ZRAM before. But he actually did write:

Which means, either he previously did not use ZRAM, or this part below isnt quite the truth:

Someone (hint) should be more interested in investigating which part is the truth.

Just saying!

Someone (hint) in the first place should follow the community guidelines .
Just saying. Then again that’s my job as a moderator not yours.

1 Like

This had nothing to do with beeing moderator. It was a simple question of taking interest of what might have happed for him since his sd card did wore out.
If he already used zram, your answer didnt help him much. Infact your answer would turn out to be wrong.

Well I tried, and failed to make you get the point. Didnt seem to matter.

I got your point. It’s in your desperate attempts to shed bad light on my person and my contributions.
Which is why I pointed you at the community guidelines. I even thought about flagging you and your “contribution” to have some other moderator properly handle this. I will do next time.
And “just saying” even if @Boby is right in his assumption that his card wore out (who knows) and he was using ZRAM (who knows) it would still not mean my statement is wrong. No protection whatsoever is ever a guarantee.

Folks, actually I’m not sure what was activated and what was not…I deactivated ZRAM when I moved to OH3.x, because everything was sooooo slow and I was sure, I moved the root to the connected SSD disk on my Raspi. But maybe I fortgot this step. However, I need to set up everything again as I ran into other troubles as well. Thank you for your contribution!

@mstormi , I got now a new Raspi 4 with a new SD card and I did a fresh openhabian installation from the scratch. Now I’m asking myself how I could find out, if ZRAM is active and being used. Do you have a hint for me? Thanks!

I have seen other commands that might be better, but for me I just run

sudo systemctl status zram-config


Thanks, works like a charm!

Hi Guys
just a stupid question. I understand that openhabian works well on the SD card using ZRAM. But what about the influx database which gets data 24/7 ? Is that also assisted by ZRAM or is this only a feature for openhab ? Sorry, i’m aware that this is a stupid question but i dont have the technical background to answer that questin by myself…

InfluxDB is on ZRAM, too.